WI-FI problem with SP4

Discussion in 'Microsoft Surface Pro 4' started by Carlore, Jan 26, 2016.

  1. Carlore

    Carlore New Member

    Joined:
    Jan 13, 2016
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Other
    Hi, yesterday I was handed the Surface Pro 4 i5 256gb 8gb (version: eu), but since the first start I had the first problem, the Wi-fi did not work well, the connection with wi-fi was slow and it continued to drop the connection, was not a problem of my modem/router or my connection, indeed my previous computer works well, without any problem. I've tried to fix it with a fix that I've found on internet, but nothing has changes.
    Moreover, probably because of wi-fi problem, it was impossible to use onenote and the store, then suddenly the started to work, but nevertheless with some error code, that are linked to issue connection.
    Someone had the same problem?
    How can I fix it?
    Thanks
     
  2. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Have you connected to any other WiFi? Process of elimination.
     
  3. Carlore

    Carlore New Member

    Joined:
    Jan 13, 2016
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Other
    Yes, indeed after that I was not able to connect the device to any other wi-fi connection
     
  4. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
  5. gtmead09

    gtmead09 Member

    Joined:
    Oct 31, 2015
    Messages:
    50
    Likes Received:
    7
    Trophy Points:
    8
    My Device:
    SPro4
    So don't think this applies, but going to add it in anyways. I had a ton of WiFi issues originally with my SP4. I also had a TP Link router which gave me various other fits from day 1. Replaced the TP Link with a ASUS, not one problem since.
     
  6. Carlore

    Carlore New Member

    Joined:
    Jan 13, 2016
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Other
    I have tried with other wi-fi connection and the problem still remain, but after I have reinstalled some update, now It seem to work.
    But, I have some more issues, in two days I have had three blocks. This morning I was not able to power on my surface, after 10 or more seconds It appears a blue screen and I had to press the power botton for almost 30s. Moreover my kickstand seem to be unsound.
    Now, I cannot decide between return it and take back my money, or try to change it. The problem is that if I return it, I will wait for mac air 2016 or pro 2016, so yet another 4/5 months and now I am with an eeepc, because I sold my previous computer, acer v nitro.
     
  7. kyrkesmith

    kyrkesmith New Member

    Joined:
    Dec 11, 2015
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Are the networks you're having problems with 5 GHz ones perchance? If so I've found that by changing the adapter settings so the Band is set to 5 GHz instead of Auto I don't have problems, although that's annoying to have to switch back when connecting to other networks.
     

Share This Page

Search tags for this page
microsoft surface wifi problem
,

sp4 wifi

,
sp4 wifi problem
,
surface 4 wifi problem