Wifi not reconnecting after wake

Discussion in 'Surface Pro 6' started by orion_134, Jul 27, 2019.

  1. orion_134

    orion_134 New Member

    Joined:
    Jul 27, 2019
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Other
    After my SP6 wakes up from sleep, it is still connected to the network but says "No internet" until I manually disconnect/reconnect.

    Thoughts?
     
  2. Turbo4AWD

    Turbo4AWD Active Member

    Joined:
    Sep 1, 2015
    Messages:
    285
    Likes Received:
    31
    Trophy Points:
    28
    My Device:
    Other
    There was a wifi firmware update released this week. Maybe look into seeing if that helps resolve the issue.


    Surface Pro 6
    Windows 10 version 1903 or greater
    • Marvell AVASTAR Bluetooth Radio Adapter - Bluetooth- 15.68.17013.110 improves Bluetooth connectivity.
    • Marvell AVASTAR Wireless-AC Network Controller – Network adapters- 15.68.17013.110 improves Wi-Fi connectivity.
    Windows 10 version 1803 or greater
    • Surface System Aggregator- 239.3101.139.0 improves battery performance.
    • Surface Integration – System devices- 4.18.139.0 improves integration between services.
    • Surface Pen Firmware Update – System devices- 3.0.10.1 resolves intermittent pen top button click failure on Surface Pen with no clip.
    • Surface Pen Integration Device – Human Interface Devices- 1.0.9.0 enables firmware update to Surface Pen with no clip.
     
  3. orion_134

    orion_134 New Member

    Joined:
    Jul 27, 2019
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Other
    Where do I find firmware and/or driver updates?
     
  4. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,861
    Likes Received:
    1,182
    Trophy Points:
    113
    Location:
    Eastern USA & China
    My Device:
    Surface Book
    What Version and Build of Windows 10 are you using? Settings, System, About

    And just as a check for your settings, make sure your network adapter is not being powered off deliberately during Sleep ...
    • Press Windows key + X key and select Device Manager.
    • Find and double-click Network adapters.
    • Right-click the device listed and click on Properties.
    • Navigate to Power Management tab and uncheck the option Allow the computer to turn off this device to save power.
     
  5. orion_134

    orion_134 New Member

    Joined:
    Jul 27, 2019
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Other
    10 home 1903. My network adapter doesn't have to that tab.
     
  6. leerandall

    leerandall New Member

    Joined:
    Jan 20, 2019
    Messages:
    17
    Likes Received:
    4
    Trophy Points:
    3
    My Device:
    Other
    Mine doesn't either.
     
  7. wpcoe

    wpcoe Member

    Joined:
    Aug 6, 2017
    Messages:
    90
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Thailand
    My Device:
    SPro
    Interesting. Win10 Pro (1903) and my Marvel AVASTAR Wireles-AC Network Controller doesn't have any Power Management settings, either. On any tab. I'm *pretty* sure it used to.
     
  8. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,861
    Likes Received:
    1,182
    Trophy Points:
    113
    Location:
    Eastern USA & China
    My Device:
    Surface Book
    Sorry for the confusion. Version 1903 has different settings menus and options. Even Microsoft's "fix" (here) does not apply, as it appears power settings for network adapters has been removed.
     

Share This Page