What's new

1080P resolution too small? Also found something interesting...

paulwpark

New Member
I bought my surface pro to replace my aging Lenovo T61p notebook with 15 inch monitor (1680x1050). I really want to be able to travel light when I travel for work and I love the Surface but when I am trying to "work" with my surface, the small text is getting to be a problem. I do a lot of RDP/Citrix sessions and even when I change the scaling on my surface to 125%, when I log onto the remote servers and workstations, the resolution is back to 1920x1080 and 100% scaling. Remote sessions aren't allowed to change scaling. So instead of changing scaling, I thought when I am not outputting to external monitor, I would change my resolution to 1600x900. After changing the resolution, when I go to the start screen, the tiles are 4 tiles high instead of 3 I was getting at native resolution. I thought Microsoft set it where the screen size dictated the number of tiles on the screen and not the resolution. I expected the WinRT side to remain the same. Anyone else notice this?

I am not decided on how to deal with the small screen size at native resolution. I will have to see what is a good compromise. But I would love to see more tiles at once when I am in the native resolution. Anyone know of a hack to allow more tiles? Registry edit?

[UPDATE] found a way to display more than 3 rows of tiles...

Go to Regedit

go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WIndows\CurrentVersion\Explorer
Create new Key called Scaling
Then Create new String Value called MonitorSize and set to 15.4

go to HKEY_CURRENT_USER\Software\Microsoft\WIndows\CurrentVersion\ImmersiveShell\Grid
Modify Layout_AvailableHeightCells to 5
Modify Layout_MaximumAvailableHeightCells to 5
Add new DWORD (32-Bit) Value called Layout_MaximumRowCount and set to 5

Reboot
 
Last edited:

GTIMKVI

New Member
Curious if you've found any relief for the resolution/scaling issue into an RDP session? Even if I set the resolution on a desktop mstsc session, it doesn't scale to full screen and the experience is horrible on the SurfacePro.

Also, have you found a way to adjust the resolution on the Windows 8 Remote Desktop App, (the metro app from the store).

thx
 
Has anyone else who does a lot of RDP noticed that while navigating Server 2003 can be a challenge, requiring a mouse of the stylus, Server 2008 appears to be touch aware?
 

ArnoldC

New Member
RDP sessions on my Surface RT and Windows 8 Enterprise has always been full screen without any borders. I prefer the Modern UI Remote Desktop.
 

polbit

Member
I bought my surface pro to replace my aging Lenovo T61p notebook with 15 inch monitor (1680x1050). I really want to be able to travel light when I travel for work and I love the Surface but when I am trying to "work" with my surface, the small text is getting to be a problem. I do a lot of RDP/Citrix sessions and even when I change the scaling on my surface to 125%, when I log onto the remote servers and workstations, the resolution is back to 1920x1080 and 100% scaling. Remote sessions aren't allowed to change scaling. So instead of changing scaling, I thought when I am not outputting to external monitor, I would change my resolution to 1600x900. After changing the resolution, when I go to the start screen, the tiles are 4 tiles high instead of 3 I was getting at native resolution. I thought Microsoft set it where the screen size dictated the number of tiles on the screen and not the resolution. I expected the WinRT side to remain the same. Anyone else notice this?

I am not decided on how to deal with the small screen size at native resolution. I will have to see what is a good compromise. But I would love to see more tiles at once when I am in the native resolution. Anyone know of a hack to allow more tiles? Registry edit?

[UPDATE] found a way to display more than 3 rows of tiles...

Go to Regedit

go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WIndows\CurrentVersion\Explorer
Create new Key called Scaling
Then Create new String Value called MonitorSize and set to 15.4

go to HKEY_CURRENT_USER\Software\Microsoft\WIndows\CurrentVersion\ImmersiveShell\Grid
Modify Layout_AvailableHeightCells to 5
Modify Layout_MaximumAvailableHeightCells to 5
Add new DWORD (32-Bit) Value called Layout_MaximumRowCount and set to 5

Reboot
I have to say that RDP at full 1080p res is a plus in my book, but you definitely need the wedge mouse for ultimate experience. This is actually one of the selling points of the Pro for me.
 

GTIMKVI

New Member
Thanks for the reply. I also personally favor the 1080p resolution. However when you RDP to another server, that resolution may not be conducive to that environment. Using the Widows 8 RDP app, you can't explicitly set a resolution or your scaling for a session, at least not that I'm aware of. Using the desktop MSTSC, you can set resolution, but not scaling, and the MSTSC window re-sizes as a window within the SurfacePro native 1080p screen. So now you are right back to tiny text on a server where you don't want tiny text.

My first reaction was there's gotta be other RDP clients that scales or manages the session differently, but I have not been able to find any relief for this.... :-/
 

magicrobots

New Member
If you're able to install the Splashtop host on your host machine, you get full control over resolution with the splashtop client - it is an awesome RDP alternative.
 

GTIMKVI

New Member
@magicrobots....thanks for the suggestion. I ran across that on the Windows 8 store and saw some favorable reviews. The challenge is that there are over 100 hosts and I was hoping to get something that worked natively, so I wouldn't have to install a 3rd party. Someone recommended Bozteck. That's too heavy of a software. I need a simple RDP client that manages resolution/scaling well.
 

cg123

New Member
Hello. If you wish to enable scaling in the native desktop RDP client (mstsc), save the connection details and then open the .rdp file in notepad and add this line:

smart sizing:i:1

This might help somewhat, sorry if I misunderstood the issue. I set remote resolution as appropriate and then use that setting to scale it to the machine I happen to be connecting from.
 

ximoosea

Member
This worked so well and really makes the Pro interface much more efficient. Thank you!

I bought my surface pro to replace my aging Lenovo T61p notebook with 15 inch monitor (1680x1050). I really want to be able to travel light when I travel for work and I love the Surface but when I am trying to "work" with my surface, the small text is getting to be a problem. I do a lot of RDP/Citrix sessions and even when I change the scaling on my surface to 125%, when I log onto the remote servers and workstations, the resolution is back to 1920x1080 and 100% scaling. Remote sessions aren't allowed to change scaling. So instead of changing scaling, I thought when I am not outputting to external monitor, I would change my resolution to 1600x900. After changing the resolution, when I go to the start screen, the tiles are 4 tiles high instead of 3 I was getting at native resolution. I thought Microsoft set it where the screen size dictated the number of tiles on the screen and not the resolution. I expected the WinRT side to remain the same. Anyone else notice this?

I am not decided on how to deal with the small screen size at native resolution. I will have to see what is a good compromise. But I would love to see more tiles at once when I am in the native resolution. Anyone know of a hack to allow more tiles? Registry edit?

[UPDATE] found a way to display more than 3 rows of tiles...

Go to Regedit

go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WIndows\CurrentVersion\Explorer
Create new Key called Scaling
Then Create new String Value called MonitorSize and set to 15.4

go to HKEY_CURRENT_USER\Software\Microsoft\WIndows\CurrentVersion\ImmersiveShell\Grid
Modify Layout_AvailableHeightCells to 5
Modify Layout_MaximumAvailableHeightCells to 5
Add new DWORD (32-Bit) Value called Layout_MaximumRowCount and set to 5

Reboot
 

GTIMKVI

New Member
Hello. If you wish to enable scaling in the native desktop RDP client (mstsc), save the connection details and then open the .rdp file in notepad and add this line:

smart sizing:i:1

This might help somewhat, sorry if I misunderstood the issue. I set remote resolution as appropriate and then use that setting to scale it to the machine I happen to be connecting from.
Gave this a try. On my surface I have 1080 with 150% scaling. When I connect to a server at "full screen"....I get 1080, but with 100% scaling....so back to the super small unusable font.
 
Search tags for this page
surface pro font too small

surface pro rdp resolution

surface pro rdp scaling
surface pro remote desktop resolution
surface pro remote desktop scaling

surface pro remote desktop too small

surface pro resolution too high
surface pro screen too small
surface pro text too small
surface remote desktop resolution

Members online

No members online now.
Top