What's new

After a few days with the new Intel 520 beta driver - excellent results so far!

bangsters

Active Member
I got the display driver error right after I updated lol... but at that time I have not rebooted yet. I have rebooted since and have not experienced it yet so far.
 

bangsters

Active Member
OK got my first BSOD today after turning on my SB from hibernate. The error was related to display driver (I was too slow to take a pic with my phone lol). Anyway, never had a BSOD until I installed the beta drivers, hopefully just a coincidence. Everything else seems to be snappy good (except for some nuances still which I don't think are Intel driver related, such as lock screen showing smaller than screen after you unlock, needing to press CTRL-ALT-DEL and back to clear it).
 

Telstar1948

Active Member
OK got my first BSOD today after turning on my SB from hibernate. The error was related to display driver (I was too slow to take a pic with my phone lol). Anyway, never had a BSOD until I installed the beta drivers, hopefully just a coincidence. Everything else seems to be snappy good (except for some nuances still which I don't think are Intel driver related, such as lock screen showing smaller than screen after you unlock, needing to press CTRL-ALT-DEL and back to clear it).

If we're talking about the same thing, my SB will be in sleep and I'll open it with Windows Hello looking for me and the lock screen is smaller than the rest of the screen. I swipe up and it disappears.

I went with the beta driver also, and it's better than before. Still some hokiness here and there, so all things not solved yet (sigh)...

I'm loving my SB, but my only real reservation is that I'm having trouble getting used to the laptop form factor after have the SP3 for over a year. I'm still having errant thoughts about returning the SB and getting an i7 SP4 in its place (better graphics with the i7 so that's why I'd go with the i7). I truly love most everything about the SB. I'm not crazy about the hokiness, but I would have that with the SP4 as well. I have to say, though, that I feel I have to be a little more careful carting around the SB since it's all metal (no type cover folded up to protect much of it) and it's a little heavier. On my lap, it's a little larger and doesn't "fit" as well while doing the couch potato thing in some positions. So, for me, I'm still wrestling with the form factor more than anything.
 

Inversion

Member
Did anyone have to uninstall first? I've done the zip file download and extract. When I try to do the manual update via device manager for graphics and the processor, it says "The best driver software for your device is already installed".

I was thinking perhaps MS pushed the drivers out in an update that I already did but considering the date of this thread, I don't think this would be the case.
 

Telstar1948

Active Member
I opened the zip file and then went to Device Manager and did a "manual" install. That is, I had it scan my computer (not the internet) and it popped up two drivers (not sure where the other one came from) and then I selected the October driver. It installed and things have been better since...as mentioned above, not perfect, but better.
 

Inversion

Member
I opened the zip file and then went to Device Manager and did a "manual" install. That is, I had it scan my computer (not the internet) and it popped up two drivers (not sure where the other one came from) and then I selected the October driver. It installed and things have been better since...as mentioned above, not perfect, but better.

Thank you. I have done those steps and get that message so I have to believe somehow I got the latest drivers installed. I recently returned my i5 for an i7 and maybe MS is now preloading the beta driver on new hardware distribution. I do note the i7 has been operating much more smoothly than the i5. For a while I was thinking it was because of the processor upgrade but now think it may have been due to this driver release.
 

jnjroach

Administrator
Staff member
Thank you. I have done those steps and get that message so I have to believe somehow I got the latest drivers installed. I recently returned my i5 for an i7 and maybe MS is now preloading the beta driver on new hardware distribution. I do note the i7 has been operating much more smoothly than the i5. For a while I was thinking it was because of the processor upgrade but now think it may have been due to this driver release.
You have to go through the "Let me Choose...." and "Have Disk" part of the manual install process, otherwise it will keep the Surface Designed Version....
 

bangsters

Active Member
ok I can say I might be the first one with major issues with the beta drivers lol.... since installing it, I've had BSODs like 4 times now, just today.

I also turned on my SB from hibernate to show a coworker the SB and the screen loaded but frozen.....

I'll keep monitoring tonight....
 

Staff online

Members online

Top