What's new

Apps won't load correctly on sp3


New Member
I just bought a surface pro 3 with Windows 10 and I have already run into some issues with it. I draw and I decided to try the artrage touch app, I downloaded the trial version and started using it for about a week. I pulled it up one day and the program came up but it had a black screen and no options. I restarted my sp3 10,000 times to no avail so I assumed that my trial must be over. I uninstalled and tried a few other apps. I ended up buying the artrage app. It worked at first but now it's back to the black screen. It will randomly work at times, like maybe one time out of 100 it will fully load. I emailed the app'shelp website and they wouldn't even reply.
I started to use the Sketchable app due to zero reliability of Artrage touch. It worked fine at first but now it won't let me open up the brush options.
This is extremely frustrating and I am thinking about returning my sp3. I have googled everything under the sun and all I can find is someone suggesting to reset the app license but I have not been able to find a way to do this on Windows 10.