What's new

Battery charging error?

Zkyevolved

Active Member
I am seeing something strange with my SP4 as of lately. Maybe someone can make heads or tails of this.
I have BatteryBar Pro, and it says I'm connected to A/C, and then shortly after it'll show me the time I have remaining (when already charged at 100%).
capture20160207164242221.png

So I ran a battery report and this is what I saw...

In regards to battery bar pro, this is what I'm seeing:

Untitled picture2.png

Untitled picture3.png


It'll cycle between these two... And then actual Battery Bar Pro upon hovering over it shows:
Untitled picture.png

and
Untitled picture4.png


Can anyone tell me if this is hardware related or software related? I have two OEM chargers, and they both show the same thing. So I know it's not the charger itself.


Update: Issue is gone, I thought I'd let everyone know what has changed. What I did was uninstall Battery Bar Pro, and then restarted, and reinstalled it again. What I believe happened is that since the last firmware update that MS released, which contained some new drivers for the battery and charging, conflicted with the BBP drivers. So I uninstalled, and reinstalled, and I haven't seen this issue yet.
 
Last edited:

GreyFox7

Super Moderator
Staff member
I think you're looking with too fine a filter, step back a bit. Even Christie Brinkley will show some cracks under the microscope. ;)
 
OP
Zkyevolved

Zkyevolved

Active Member
I think you're looking with too fine a filter, step back a bit. Even Christie Brinkley will show some cracks under the microscope. ;)
So you don't think this is worrisome? I mean, nothing is wrong with it? On my last Surface Pro 4 I had battery bar pro hide itself when it was at 100%, and now it appears and disappears constantly... I changed it to just always show, but I know this wasn't there on my last SP4. Could this be a hardware issue?
 

jnjroach

Administrator
Staff member
I know that this is a popular utility but I've never seen that the developer has updated the code to properly detect S0iX power states, the code base is the same as it was when released for Windows Vista.
 

jnjroach

Administrator
Staff member
Is your concern that it is showing that it is on battery while plugged in to mains?
 

hughlle

Super Moderator
Staff member
I've regularly seen mine plugged in charging, plugged in not charging, plugged in charging. I've never given it the time of day.
 
OP
Zkyevolved

Zkyevolved

Active Member
Is your concern that it is showing that it is on battery while plugged in to mains?
Yes, it looks like it disconnects from the AC and then runs off of battery for 10 seconds to a minute (depending if it's on or in sleep mode) and then back to AC.
 

jnjroach

Administrator
Staff member
Yes, it looks like it disconnects from the AC and then runs off of battery for 10 seconds to a minute (depending if it's on or in sleep mode) and then back to AC.
Uninstall Battery Bar Pro and see what happens after 24-48 hours after you run the report.
 

GreyFox7

Super Moderator
Staff member
It could just be a change in behavior as I believe there was a recent change to "battery charging"
 

dcoplien

Member
I am seeing something strange with my SP4 as of lately. Maybe someone can make heads or tails of this.
I have BatteryBar Pro, and it says I'm connected to A/C, and then shortly after it'll show me the time I have remaining (when already charged at 100%).
View attachment 7866
So I ran a battery report and this is what I saw...

In regards to battery bar pro, this is what I'm seeing:

View attachment 7868
View attachment 7869

It'll cycle between these two... And then actual Battery Bar Pro upon hovering over it shows:
View attachment 7867
and
View attachment 7870

Can anyone tell me if this is hardware related or software related? I have two OEM chargers, and they both show the same thing. So I know it's not the charger itself.
I'd like to know why my capacity went down and yet shows no wear. My SP4 is only a couple of weeks old.
 

Attachments

OP
Zkyevolved

Zkyevolved

Active Member
Uninstall Battery Bar Pro and see what happens after 24-48 hours after you run the report.
I've just removed it, let's see if anything changes. I'll put it back to sleep now and try again in an hour to see.

It could just be a change in behavior as I believe there was a recent change to "battery charging"
Yes? Something has changed? Do you mean in the last firmware update? Surface Embedded Controller Firmware (v103.899.256.0) adds battery charging enhancements and thermal tuning.

Can anyone else confirm that they're getting the same battery usage on their SP4 while asleep, or awake, while plugged in at 100%?
 
Search tags for this page
surface 3 charging problems
surface book not charging
surface pro 4 battery not charging

urface battery error pluged not charging

Members online

No members online now.
Top