What's new

Cannot Edit SharePoint 2010 Site with Surface Pro

JerryC999

New Member
I am the owner of a personal SharePoint site, which I have been managing from my old laptop running XP. I now have a Surface Pro, but when I attempt to edit my site pages, I get an incomplete set of edit options (cursor displays on page, page tab options are greyed out, other edit tabs are missing). I can make changes to the page, but nothing saves. As for document libraries, I cannot upload new content, or save any edits in the properties forms. However the site still functions properly from my XP machine, so it can't be the site.

Are there browser settings I need to change? (Please don't tell me you can't edit a MS SharePoint site from an MS Surface Pro.)

Tried to upload a PNG image of it to this post using the MS Snipping Tool on my MS Surface, but that is not working either.

I have also tried to attach the image to this post, but all I get is a circling arrow that never completes.

Ideas? Explanations?
 
OP
J

JerryC999

New Member
That was it! Thank you.

Question, though - why would a SharePoint 2010 site require a lesser version of IE to operate? Is it because it is not SharePoint 2013? And in a related question, does this very forum require a browser that runs in compatibility mode, since I could not insert an image or attach one? Or is this because the site needs to operate within a broader range (read: earlier versions) of IE?
 

ArnoldC

New Member
This site, like all vBulletin sites I participate in kinda sucks in IE10. PHPBB-powered ones are darn good.

There are code, techniques, that are not compatible with IE10 and the new web standards.
 
Search tags for this page
can you edit sharepoint on surface
sharepoint 2010 and surface pro 4
sharepoint 2010 and surface pros
sharepoint 2010 surface pro

sharepoint on surface pro

sharepoint open in explorer greyed out on surface pro 3
surface pro 3 sharepoint edit page
surface pro issues sharepoint 2010
surface pro unable to edit in sharepoint
surface pro with sharepoint 2010

Members online

Top