What's new

Cannot get SP2 to recognize Power Cover. But the keyboard functions works ...

Dicken Wong

New Member
hi. i was trying my power cover to work on SP2. I dont really know its history as the unit was given to me. But these are clues and maybe somebody cans see whats wrong with it.

1. The unit was given to me in this state
- power cover's battery function is not working. Then, SP2 would displayed 2 batteries. But the power cover battery would have a 0% charge (plugged in, not charging). Keyboard works though
- Device manager Firmware would have it as
Firmware Resource
Firmware Resource
Firmware Resource
Firmware Resource​

2. I sensed that it could be driver issue so I downloaded the July 2014 FW and manually installed most of the FWs. It is now in this state
Device Manager
Batteries
Microsoft AC Adapter
Microsoft ACPI-Compliant Control Method Battery​
Firmware
Firmware Resource
Surface Pro Embedded Controller Firmware
Surface Pro System Aggregate Firmware
Surface Pro UEFI​
Keyboards
HID Keyboard Device
Surface Type Cover Filter Device
3. No pending Windows 8 updates. Although on the update history, I dont see any history of Surface FW updates. The closest thing to that are MS-Other hw-Touch Cover trackpad settings and MS-Keyboard-Surface Type Cover.

4. Battery tray only reported 1 battery.


This is all I can think of. Tried practically everything suggested on the web.

Thanks.
 

toaf

Member
i had the same thing, i think updating while it was hooked up (not in docking station worked to jolt it going small chance unhooking it while charging might pop it normal. with the charging issues going on might take morepoking.
 

infer66

Member
My power cover just worked from the first boot up. No updates needed. Just pluged in and was ready to go. Maybe try cleaning the power connector nibs on the cover and try again.
 
OP
D

Dicken Wong

New Member
tried it and practically every suggestion i can find of the web ... still the same result, thanks.

also, only the battery function is having a problem. it still works as a type keyboard.
 

Members online

No members online now.
Top