What's new

Solved Cannot recover surface from Win10


I have a SP3 with the primary partition as Win10. Everything is actually fine but I have to repurpose the device for someone else. I originally tried doing the native "reset" which reset it fine, but reset to Win10 (I didn't realize that upgrading to the tech preview changed the stock recovery partition).

I then went here: https://www.microsoft.com/surface/e...ervice-and-recovery/downloadablerecoveryimage and downloaded the .zip. Next I took a flash drive, formatted it to FAT32 and unzipped the files from the zip to the flash drive. Basically the root of the drive includes the list of language sub folders and the bootmgr files. I loaded the recovery console boot menu and went to "reset" and "partition" and when it says insert a flash drive, I insert it but then it says the media inserted is not valid.

What next?


Thanks for sharing. I'm doing that now. Is that pulling from the media though or internal partition?


Super Moderator
Staff member
To go back to 8.1 you have to wipe the W10 partition which the procedure linked above does.
That error message could be more informative... Like sorry, can't let you recover W10 with a W8.1 Recovery Drive.
The Repartitioning Option is important as well. IMO turning off and restarting is not necessary you should just be able to exit the Command Prompt then go back to select the Reset option and proceed from there.