What's new

Cannot set proper refresh rate for external monitor after latest update


New Member
Somewhere in the last month or so, there was an update to my SP2017 and now my external monitor (Samsung T240HD, 1920x1200) no longer displays. It's connected by a DP to HDMI connector, and up until recently, worked perfectly.
Something in a recent Windows update seems to have borked the Intel driver for the external port. If I set the resolution lower and change the refresh rate, I can see a display, but if I set it to the monitor's native resolution of 1920x1600, there are only 2 refresh rates available, 59.99 and 60. In other resolutions there are more choices and 60i or 30p work fine as do some of the 59-ish rates. Those refresh rates are not available when selecting 1920x1600.
I cannot roll back because it's been more than 10 days. I tried downloading a new driver from Samsung, I installed the Intel Display management software (forget the exact name), neither has helped. don't really want to have to install windows again from scratch, I just want my old monitor settings back!