What's new

Can't Force Screen to Not Lock?


New Member
I asked about this over on EightForums but the people over there aren't as familiar with the Surface RT as you guys are.

I am using a Microsoft account on my Surface RT, and using "control userpaswords2", unchecked the "users must enter a password" option so that I can start the tablet without having to type my password. With the stock Windows RT that came with it, this worked great and I never needed to type my password except for store purchases... but now that I have the 8.1 preview (which I like for everything EXCEPT this stupid password nonsense), there is now a mandatory option to lock the screen after X minutes, with 15 being the highest. If you're using a local account you can tell it to never lock, but this doesn't work for Microsoft accounts.

I came across this after exporting my registry before and after adjusting the time:
That was when I had it set to 5 minutes.

That's when it's on 15 minutes.

The key is under
[HKEY_USERS\S-1-5-21-[GUID thingy]\Control Panel\Desktop]

If I set that to 0, it always locks, but if I set it to something high like 999999, the tablet doesn't acknowledge that and still shows 15 minutes. Even though the registry still has it set as 999999. If I change it manually between 12C and 384 it DOES reflect that change in PC settings.

Is there some other work-around, whether using the registry or a group policy setting, that can force my tablet to not lock itself? I hate typing in my password, I'm the only one who uses the device and since you need a password to do anything money-related I feel it's safe enough as it is.

If not, I'll just have to hope they fix this problem with the RTM 8.1...


Active Member
I too am searching for a solution.

I've seen something while searching for the same thing where you can disable the lock screen. I didn't research it further as I actually use it. There are times that it needs to not lock though and it is annoying.


Well-Known Member
I also hate having to type my password in all the time so simply changed to a local account, although I know that's not ideal for everyone.