What's new

Copying files hangs


New Member
Copying files to and from external hard drives usually hangs part way through the copy process, especially when I use a USB hub and copy between external drives or memory sticks. The same process works fine on my tower running Windows 7. I've tried numerous solutions found on the internet and nothing seems to help. A common answer is that the Surface Pro 4 doesn't supply enough power via the USB port so I bought a powered USB hub but that didn't solve the problem. Another common suggestion is to turn off write caching but that didn't help either. Any assistance would be greatly appreciated. Thanks.


Super Moderator
Staff member
Hello, @PeterFrostad

Welcome to the forum. Welcome.

Okay, this must be really annoying. I think something is amiss with your Windows installation. Have you tried using Settings, Update and Security, Recovery, to reset or re-install Windows? I know that sounds drastic, but this is indeed a serious problem, which does not seem to be hardware related.


New Member
Actually I think I'm on to something because I have two towers, one with Win 7 and one with Win 10 as well as my SP4 which is Win 10. Both Win 10 machine exhibit the same problem. Coincidentally, both Win 10 machines have USB 3.0 which I was using. When I switch to using a USB 2.0 port on my Win 10 tower, the copy process works fine. So I don't know yet if it's a Win 10/USB 3.0 problem or just a USB 3.0 problem. BTW, how I got on to this was I found an internet post where someone solved the problem by putting a male/female USB 2.0 cord between the computer and their USB 3.0 external hard drive.
Last edited: