What's new

Curious Issue with Start Button


New Member
Just upgraded to 8.1 (thanks, Omni) and it's looking good so far. Kept all of my apps and personal files/settings, so I was really joyed about that. I cleaned my Type Cover as well; almost feels like a brand new Surface!

Anyway, I have an odd problem...As some of you may know, I have the updated Manvex case for my Surface, and it has worked great! (I cleaned it during the update as well). Now though, well, I don't know the best way to explain it...

When the case is on, the start button does not work. When the case is off, it does work. There is a leather border on the case that runs along the bottom of the Surface, and has a cutout for the start button. If I lift this flap up, so that it is not resting on the Surface (like it is supposed to, and has been for months with no issue), the start button works just fine with haptic feedback and all. If I let go and let the flap rest on the screen, the start button does not work. Mind you, the start button has always worked whether the case be on or off.