What's new

explorer problems

dharma

New Member
I've had the Surface for about a week & was loving it... but suddenly when I go to a forum that worked perfectly until 2 days ago, I can't open any of the threads unless I touch & hold the link & click Open, and often that doesn't even work. Using the keyboard cursor doesn't work either. A little box pops open that says "make a new post in this topic JavaScript"... in fact, it's still showing on top of this window as I type this.

I've done the windows updates, rebooted several times, logged in & put of the site...I'm not terribly tech savvy and expect the machine to just WORK, so I must be missing some basic piece of information... how do I fix this?

Also, many times when I click on a typing field, the keyboard doesn't show up unless I swipe from the right & select it...which doesn't always work. Is this related?

I so want to love this machine but now I just want to cry. I've never had this kind of trouble with laptops, desktops, iPad, etc., and this thing makes me feel like a total idiot.

Hellllp!!! :tongue:
 

bosamar

Well-Known Member
Sounds to me like you are browsing from the Desktop IE. Go to Control Panel > Internet Options > Advanced > Reset Internet Explorer settings. If you ARE in fact browsing IE from the Desktop the keyboard will NOT auto-pop, that's the way the Desktop works; you have to open the keyboard manually by clicking on the icon in the taskbar. The keyboard only auto-pops in the Modern UI.
 
OP
D

dharma

New Member
No, I'm using the little app icon from the tiles page... but I'll give the reset a try, thanks!!
 
OP
D

dharma

New Member
Did the reset & all it did was delete all of my favorites, give me msn as a homepage, and close all the windows I had open so now I have to hunt everything down. Still can't click on anything and still have a little box overlaying this page (from the other forum) that says "view the first new post in this topic". The weirdest thing is that it worked fine for days & then... well... didn't!

Anyone wanna buy a barely-used Surface? :wink::tongue:
 
OP
D

dharma

New Member
Found my favorites... or more accurately, they found me... but still can't click with touch screen or keyboard on those links. They seem to work fine here though.
 

J515OP

Super Moderator
Found my favorites... or more accurately, they found me... but still can't click with touch screen or keyboard on those links. They seem to work fine here though.
Or do you mean the links on the other forum won't work (not your favorites links)? Is it just that one site? It is possible the issue it that site (just like this one has its issues).

JP
 
OP
D

dharma

New Member
They don't work on the other forum. I have no problems with them from the iPad or my old laptop so unless it's a communication issue between the Surface & the site it doesn't seem to be just the site. I haven't had the same problem with other sites.
From the Surface they will sometimes eventually open with the keyboard, but I have to click on them a dozen or so times OR hold down the left-click (when I do this, the link sort of blinks very rapidly) and then wait a moment. I have better luck opening them with the keyboard than the touch screen; with the touch screen they rarely open at all.
 

J515OP

Super Moderator
The site is probably not touch optimized. Particularly if the links you are having trouble with are in drop down menus. Most likely these menus are coded for mouse hover which touch can't replicate. The site may serve up different versions based on the browser.

Also likely and perhaps additionally to those issues, many sites are not setup for the newer versions of Internet Explorer. This is actually quite common. Here is a tool you can use to check the site for IE issues Scan a webpage | Testing made easier in Internet Explorer | modern.IE.

JP
 
OP
D

dharma

New Member
Thanks, that was pretty cool! It did say it found issues with "frameworks & libraries". I can notify the site admin about updating, but any idea why it would have worked just fine for almost a week & then just stopped?
I love having the ability to touch the screen AND use the keyboard (let's see hubby do THAT on his MacBook Air)! :wink:
I'm going to do that check on all my most-used sites now just out of curiosity... :p
 

J515OP

Super Moderator
My best guess as to why it stopped working is that there was a change made to the site itself. You can try using desktop browser compatibility mode to see if that helps.
 
OP
D

dharma

New Member
Oddly, it worked great in compatibility mode until I tried to click on the last link I was planning to read & I couldn't open that one at all- nothing happened with touch or keyboard.
Weird, but no crisis, just a curiosity.
 
Search tags for this page
internet exlorer problems with surface

internet explorer surface problems

microsoft surface internet explorer problems

problems with surface internet
surface ie issues
surface internet explorer issues

surface internet explorer problems

surface internet explorer troubleshooter
troubleshoot internet explorer issues on surface 2
windows surface problemswith tabs webpage

Members online

Top