What's new

Feeling like I've bought the wrong surface

viccles

New Member
I bought a surface just to take to uni do office tasks and I just find its quite laggy. I'm just not sure whether I should have bought a pro instead
 

Ruffles

Active Member
Have you done all the updates? I don't have an RT but my understanding was that originally it was a little slow but then MS released updates that improved it.
 

pallentx

New Member
Where are you seeing lag? I don't see any lag navigating around and running mail, web browser, etc. The Xbox Music app seemed to slow things down a bit, but that is fixed in the 8.1 preview. Maybe if there is a specific use that is slow for you, there may be ways to speed it up. I also found that accessing files on a SD card was noticeably slower.
 

Omni

Active Member
I notice some lag on my RT (still RT 8) but only on the desktop. Excel is quite bad with large worksheets, but not bad enough for me to spend double the money on a Pro.
 
OP
V

viccles

New Member
I installed Windows 8.1 using the workaround method (had to edit reg because it wouldn't work otherwise - I'm in Australia) and it just seems opening things are laggy. Another issue I have is the wireless drops out frequently and I can't seem to send messages from my outlook exchange webmail
 
OP
V

viccles

New Member
I ended up paying a restock fee and returning my RT. Am most impressed with my 64gb pro!
 

pallentx

New Member
Glad you found something that works for you. 8.1, as a beta, has some issues. I fixed the mail thing, but uninstalling and reinstalling the mail app. Some apps open much fast with 8.1, some seem to be a bit slow. If seen the same behavior on pretty much all ARM based tablets. The iPad2 I used to have was the same - slow to launch compared to a full-powered desktop, but once open, everything was smooth. Most of my apps open in just a few seconds though - it hasn't been an issue for me, but it seems to depend on the app.
 

pallentx

New Member
For example. I just opened Excel on my Surface, then on the Desktop. 8 second on the Surface, 7 seconds on the desktop.
 
OP
V

viccles

New Member
I'm wondering if it was the 8.1 beta that was the issue. I had to hack the reg to get it working on my aus machine as well. I really needed outlook for work though. But am glad to have made the decision (would have cost me a little less $$$ if I had decided that in the first place!) but oh well
 

ArnoldC

New Member
I'm wondering if it was the 8.1 beta that was the issue. I had to hack the reg to get it working on my aus machine as well.<snip>
The preview was released to a limited number of countries, many, including Australia, New Zealand, United Kingdom, didn't get it, thus the need for the hack for people like us.
 
Search tags for this page

bought wrong surface

i bought the wrong surface

Members online

Top