What's new

Issue connecting to projector

Zkyevolved

Active Member
Hello everyone. I just got back to work on Monday, and I use my SP4 to connect up the projector. I just exchanged my i5/4/128 for the i5/8/256, so it's a new device in theory. Up until the end of December I was using the i5/128 and it worked fine with no issues.

Anyways, my issue is the following: I connect the projector to my SP4 and it doesn't recognize it. I mean, it shows up in the device manager. Pressing Windows + P and I select extend or duplicate and it doesn't do anything, it just stays on the Win+P screen. SOMETIMES though it does work, but the projector screen will turn off. So I thought "Oh god, the projector is going bad, or the cable, or the adapter" so I brought it home, disconnected my desktops hdmi cable, and connected it to my SP4 with a different cable, and a different adapter (I keep one at home and one at work). It recognized the monitor but it didn't let me switch to it! Same thing: Win+P goes to the project screen and I can click one but it doesn't disappear after clicking it...

I just wanted to confirm that this is a software bug and not a hardware failure, because I connected my SP2 and it worked just fine. I downgraded the drivers for the graphics card and it worked for one day. But one time, connecting to the projector the screen turned off and wouldn't turn back on (it froze) so I had to power volume the thing and reboot it, but then it worked. So... I'm not sure what to think.

Is anyone else having any of these issues?
Thanks!
 
OP
Zkyevolved

Zkyevolved

Active Member
I am sure all drivers were up to date. I think it might be the December driver that messed it up since I rolled back and now it's working ATM.
 
Search tags for this page

connect epson pro z8000wunl to surface pro issues

connect to projector issue

connecting surface to projector issue

surface pro 3 doesnt recognize epson projector

surface projector issue

Top