What's new

Micro USB/charging issue?

adambravo

New Member
Recently went to fire up my S3 at work only to discover the battery was dead--despite having disconnected it from an overnight charge (on the official charging unit) that morning. Went home and discovered that, even though the charging cord light was on (which I assumed meant 'charging'), it wasn't charging the battery. Had to wiggle the cord a bit before the charging actually began. Today, plugged it in--no problem. My brother (who works for Microsoft) thinks he's seen reports of this and it might be firmware related. Thoughts?
 

GreyFox7

Super Moderator
Staff member
Might be the cable or some other weird micro USB issue. I connected my battery pack to charge, hours later still only showed one light. Disconnected and reconnected, still nothing after a couple more hours. Switched chargers, nothing. Then tried another cable and it started charging. Later to confirm the cable was bad I connected the charger to the battery pack and it worked. Thoughts... micro USB charging sucks.
 

leeshor

Well-Known Member
My thought is that firmware is NOT where the issue lies. Most likely the port or the cable which would be hardware.
 

malberttoo

Well-Known Member
Agreed, probably an issue with the charger. You should have no issue getting Microsoft to replace it.
 

Staff online

Members online

Top