What's new

New (minor) issue with latch failure

JBCF

Member
Since the Fall update I've been having a minor latch failure issue. Whenever I use the software or hardware detach I receive the red 'failed to detach' error message but only the message, I still get the audible click and I can still detach so it's simply an erroneous error message not an actual failure. Minor annoyance and not a show stopper to me - I'm sure it's something simple that will be resolved in a patch down the road. Worth noting that when I reattach I get the correct green 'attached' message. I've tried the two button restart in hopes it would clear things up but no joy.

Other than this, on the whole my Surface Book has been pretty docile and well behaved, a few trackpad and keyboard failures here and there, audio pops in Edge but nothing major.

Anyone else getting this? Any ideas? Maybe I can escalate to a three button restart?;)
 

astroroxy

New Member
The click you hear is fake. If you have this message you have a hardware failure and it will get worse, trust me.
 
OP
J

JBCF

Member
I know the click is a simulation. I also know there have been hardware failures on the detach but I have not had a hardware failure, the screen attaches/detaches every time.
Has anyone had the message only (without hardware failure)? Did anyone who did have the hardware failure receive the error message (without hardware failure) prior to being unable to attach/detach?
What I'm trying to determine here is whether or not I am heading for a hardware or failure or if it's just a driver or config issue causing the message to display incorrectly.
 
Search tags for this page
book latch failed to open
latch failed surface book
latch failed to open surface book
latched failed to open surface book
minor surface failure

surface book detach hardware failure

surface book failed to detach but still

surface book latch failed to open

surface book left latch not detaching

surface detach hardware failure

Members online

No members online now.
Top