What's new

New Surface Pro 3 Owner

jase

New Member
Hi everyone.
I just recently got myself a Surface Pro 3, i3 64gb.
First off I upgraded the SP3 from 8.1 to Windows 10.
I then eventually worked out how to get into the UEFI and how to boot from a USB which incidentally needed to be formatted with FAT32. Once I managed to get Win 10 installed that's when the fun began. I ran into so many difficulties with Windows Update which I think was down to the wifi connection. I read in a few places that there was an issue with the WiFi and also read on this forum that if you had a Bluetooth mouse attached it could interfere with the WiFi. I did have a Bluetooth mouse attached so I removed that and the WiFi seemed to improve a little.
I then had to change some of the settings on my router. I took off the 5GHz wireless connection and just let it connect via 2.4GHz and this improved the connection also.
Oh and what an effort it was to get the 15/09/15 firmware update to install. It kept failing all the time but eventually I got it installed.
I then did another fresh install of Windows 10 as I felt had ironed out some of the issues but I had to install the firmware update again. Is this normal as I would have thought once its done that's it, much like a bios update?
Could someone clarify this please?

Any tips would be welcome and please tell me that other people had some of the same issues as myself just so I know I'm not alone.

thanks
 

sharpuser

Administrator
Staff member
Glad you got it sorted.

And, yes, many of us are bugged by firmware updates repeatedly wanting to update. Microsoft recognizes this problem.
 

Members online

Top