What's new

New Firmware - July 8, 2014

bluegrass

Well-Known Member
Finally got my firmware update this morning. The firmware is dated 7/8/2014. Not sure where you folks are getting all these wifi rev numbers from. Mine just said firmware July 8th. Also a lot of people talk about speeds upwards of 50mhz. I'm sure that is just the speed between your Surface & your router and not your connection speed to the Internet.
 

foghat

Member
I installed the update last night. This morning it could not find my wifi hardware (this had happened a couple time before as well) . <sigh> reboot fixed, but still...
 

samurai

Member
Hi guys,

The previous surface pro models suffered with Bluetooth mouse lag when wifi is on. Can anybody check if this is the case for surface pro 3 too?
 

wynand32

Well-Known Member
Finally got my firmware update this morning. The firmware is dated 7/8/2014. Not sure where you folks are getting all these wifi rev numbers from. Mine just said firmware July 8th. Also a lot of people talk about speeds upwards of 50mhz. I'm sure that is just the speed between your Surface & your router and not your connection speed to the Internet.

Yes, this is the speed between the router and the SP3. However, for some folks, that's precisely what's been limited to 6Mb/s or so, which of course isn't very helpful if your Internet connection is 6.1mb/s or higher.
 

wynand32

Well-Known Member
I closed my Type Cover this morning at about 1am with the battery fully charged, and this morning at about 9:30am I hit the power switch. My SP3 was still at 100%, and as far as I can tell email was updated. So, yes, it looks like at least Connected Standby improvement is improved.

Now, if battery life in-use will be improved, I'll be pretty happy.
 
OP
C

clrk9000

Member
Hi guys,

The previous surface pro models suffered with Bluetooth mouse lag when wifi is on. Can anybody check if this is the case for surface pro 3 too?

I am using Apple Magic Mouse (bluetooth) and Microsoft Wedge Bluetooth KB. It works perfectly, no perceivable lag whatsoever whether with stock and updated firmware.

HOWEVER, I noticed that the Sony bluetooth speaker I am using will cut off (choppy sound ) momentarily whenever I use the mouse or keyboard.

EDIT: I unpaired and repaired and noticed now that bluetooth speaker is working well now. I can type with the BT KB and play with the BT mouse and there is no choppiness in the sound nor any lag in either KB nor mouse.

And the strangest thing, I am experiencing no WIFI limited now too.

Very happy now with my SP3.

EDIT: Wifi Limited is still happening although not as much as before. Not so happy now.
 
Last edited:

jimp

New Member
I received the update yesterday. I was not able to verify my battery level this morning, but it defintely wasn't worse.

Wifi is another story. With the new wifi driver, I'm back to the "missing hardware occasionally on resume" syndrome, where a Scan For New Hardware (or reboot) fixes it immediately. I had this problem with the original firmware, I did not experience it (I think) with the June firmware update, and now it's happened twice since I got the July driver update yesterday. The Wifi speed on battery is much better, but it's disappointing the wireless hardware is dropping out of the Device Manager again. I wouldn't think that issue would be so hard to fix. It's not having trouble connecting to any AP. It's behaving like a USB device that's unplugged between sleep and resume (randomly, rarely, the same issue many have reported around here).
 

WorldIRC

Member
I closed my Type Cover this morning at about 1am with the battery fully charged, and this morning at about 9:30am I hit the power switch. My SP3 was still at 100%, and as far as I can tell email was updated. So, yes, it looks like at least Connected Standby improvement is improved.

Now, if battery life in-use will be improved, I'll be pretty happy.

So your WiFi was running AND your battery didn't drain?
 

yonghong

Member
I closed my Type Cover this morning at about 1am with the battery fully charged, and this morning at about 9:30am I hit the power switch. My SP3 was still at 100%, and as far as I can tell email was updated. So, yes, it looks like at least Connected Standby improvement is improved.

Now, if battery life in-use will be improved, I'll be pretty happy.


Usually from 100% to 99% = more than 5% battery.
 

Members online

Top