What's new

pen questions. need help

romz26

New Member
I got my new sp3 last week and didn't start using the pen last night. It worked for the most part except the top button. Looked in the settings and it says the pen drivers are bad. I got the driver from the ntrig website and that didn't help.
So I Google my problem, and the Microsoft support site says to replace the button batteries. Will the pen even work with those batteries dead?

Do you guys think this will solve my problems?

Fyi:iam loving my surface. I finally have something reasonable to replace my aging Lenovo x200t. Miles better then regular tablets(ipads and Samsung tabs)

Thanks romz
 

mohcho

Active Member
Remove it from the Bluetooth pair settings and add it back in. Press and hold the purple button for 7 seconds until you see the green light in between the clip start blinking to enter pair mode for the pen.
 

malberttoo

Well-Known Member
I got my new sp3 last week and didn't start using the pen last night. It worked for the most part except the top button. Looked in the settings and it says the pen drivers are bad. I got the driver from the ntrig website and that didn't help.
So I Google my problem, and the Microsoft support site says to replace the button batteries. Will the pen even work with those batteries dead?

Do you guys think this will solve my problems?

Fyi:iam loving my surface. I finally have something reasonable to replace my aging Lenovo x200t. Miles better then regular tablets(ipads and Samsung tabs)

Thanks romz

Welcome to the forum! I came from an X201T.

Did you not do the pairing procedure when the Surface asked you to, when it was turned on for the first time? You shouldn't have needed any additional N-Trig drivers.
 
OP
R

romz26

New Member
Yes I have tried to re-pair the pen to the sp3, but end up with the driver error notice.

I also did pair the pen to the tablet when I first set it up, but didn't test out the functions. Thanks for the welcome btw.

I am going to take out the button top bats to see if the pen still inks. I have a suspicion it is those little buggers.

Will be back
 
OP
R

romz26

New Member
Took out the button cell batteries and the pen still inks. I may get replacement batteries today to rule them out.
 

bluegrass

Well-Known Member
You shouldn't have dead batteries if your system is new. I read that the button batteries should be good for a least a year. BTW the bottom buttons and the writing with the pen doesn't use Bluetooth from what I have read. They just use the AAAA battery.
 
OP
R

romz26

New Member
You shouldn't have dead batteries if your system is new. I read that the button batteries should be good for a least a year. BTW the bottom buttons and the writing with the pen doesn't use Bluetooth from what I have read. They just use the AAAA battery.


Yah that's what I thought also. Pen still works great except the top button. I am thinking the button was pressed in the box. The pen was not in its slot when I opened the box.
 

Members online

Top