What's new

Pro 3 pen works on other touchpads, just not on my Pro 3


New Member
I am having one of the weirdest issues. I bought a used Surface Pro 3. I started with a factory reset and things have been going very well setting up, undervolting and etc, now there's a weirdest phenomena I do not know how to solve;
I have fresh batteries on the OEM stylus that came with it, and the top bottom works perfectly fine, now if I use the pen tip on the surface pro, it simply doesn't get picked up at all!

The touchscreen works 100% fine with my fingers, just cannot pick up anything that I press down with the pen tip. So I got curious and tried using the pen on another machine and it works just fine.

I tried doing everything mentioned online such as diabling/re-installing the drivers and also I don't seem to have Intel(R) precise tough device in the device manager. I also tried hard reboot, startup rwpair dism repair chkdsk and etc.

What am I doing wrong?

What's going on? Touch isn't bad, pen isn't bad but those two cannot work together.