What's new

Properly calibrating the pen

Codevine

New Member
Hey guys,

my Pen is off A LOT in the edges, so I used this calibration to fix it. It actually worked pretty well, but when I installed the official Wacom drivers the Pen is off again. Sadly, I can't use that calibration while having Wacom drivers installed, it just says I have to reset the calibration settings. If I do reset the calibration settings nothing changes. Only when I deinstall the Wacom drivers I can properly calibrate my pen.

How did you guys handle it and how does it work? :/
 

Igor

New Member
I have not found a good way to calibrate the pen with the new Wacom drivers installed. I spent hours searching for a fix but it seems that it's either 100 point calibration OR Wacom drivers, not both. The only thing you can do is use Wacom's crappy 4 point calibration. There's even a thread about it on Wacom's own forums where a Wacom representative has said they would pass on the request for better calibration to the tech team, but that was a while ago and I don't think anything will come of it.

If you find a solution, please let me know.
 
OP
C

Codevine

New Member
Thanks, spectre51! That actually worked, probably because it doesn't use the "devicekind=pen". I'll try to use the 273-point calibration without the "devicekind=pen" later this day and see if it works out. Pen calibration is a bit better now.

@Igor
Yeah, it also took a while to even get the Wacom drivers, so they might be a bit slow. :D
 

Igor

New Member
Awesome thanks spectre51. Removing "devicekind=pen" did the trick.

I ended up using this:
tabcal lincal novalidate XGridPts=10,60,110,160,260,360,460,560,660,810,960,1110,1260,1360,1460,1560,1660,1760,1810,1860,1910 YGridPts=10,60,110,160,250,400,540,680,830,920,970,1020,1070
 

Arizona Willie

Active Member
I hadn't paid too much attention to the pen location. It hadn't bothered me so I put the pen at all four corners and it seems to be right on target.
I was expecting to find I would have to go through the setup and try to fix it and was surprised to find mine came straight from China all set.
 

ncameron

Member
I find that if I use ANY kind of Custom Calibration, I lose the ability to bring up the Auto-Hidden Taskbar at the bottom of the screen with a pen swipe; which is very inconvenient. Am I the only one with this issue?
 

sweitz

New Member
Awesome thanks spectre51. Removing "devicekind=pen" did the trick.
I am using the string without the devicekin=pen and still getting the error about Linearity Data being present. Resetting it in the Tablet PC Settings does not do anything, since calibration is being controlled by the Wacom Pen Tablet Properties, not the Tablet PC Settings. There does not appear to be a button to reset the Wacom Pen Tablet Properties, either. Also, this is the only place where I've seen that people have successfully used this calibration method while having the Wacom Feel drivers installed; all other sites say it is one or the other: Wacom drivers allowing for full pen pressure in programs like Photoshop, but only 4 points of calibration, or 100+ points of calibration using Windows drivers, and only getting pressure sensitivity in Sketchbook Pro (not Photoshop etc.).

Are you sure that you have the Wacom Feel drivers installed? If so, do you have any further tips?

Thanks.
 

sweitz

New Member
Ok, this is odd - I found a tip on another site that detaching the keyboard allows the command-line calibration to run... and it does. Running the exact same with the keyboard attached let me do the calibration with 200+ points. I am not sure if the calibration took hold, mind you (because I read elsewhere that the Feel driver calibration overrides the Windows calibration), but at least the utility runs now. I'll do more digging to see if the calibration is actually working or not.
 

xiaohang07

New Member
Good news: I have found a solution to enable us to calibrate stylus with user-defined grid when Wacom feel driver has installed on your surface pro.
The trick is to edit the registry and no risk at all if you do it properly. Most of surface pro users experience LinearityData error when run the script:
tabcal lincal novalidate XGridPts=0,30,50,150,350,650,945,1240,1540,1740,1840,1890,1919 YGridPts=0,30,50,150,350,630,830,1030,1050,1079.
Note that delete 'devicekind=pen' in the script(the script above is an example) does not solve the problem most of the time.

The solution is to delete the [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\HID\VID_045E&PID_0799&MI_01&Col03\8&2d6be41e&3&0002\Device Parameters], [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TabletPC\LinearityData] and [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TabletPC\UserLinearityData] using your registry editor.
Note that the id "VID_045E&PID_0799&MI_01&Col03\8&2d6be41e&3&0002" of the first key's name could be different on your device. A search in registry for LinearityData is suffice to find it.

Then you are able to run the 'tabcal lincal novalidate XGridPts=0,30,50,150,350,650,945,1240,1540,1740,1840,1890,1919 YGridPts=0,30,50,150,350,630,830,1030,1050,1079' script.
In this step, the values in [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\HID\VID_045E&PID_0799&MI_01&Col03\8&2d6be41e&3&0002\Device Parameters], [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TabletPC\LinearityData] and [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\HID\VID_045E&PID_0799&MI_01&Col03\8&2d6be41e&3&0002\Device Parameters] are updated.
Bingo! You get the same accuracy in the corners as the one without Wacom driver.
To backup the linearityData, use the registry editor to export these three folders(the first one is the most important). You can recovery to this profile whenever you want. Is that nice?
Now you can also calibrate your pen using the default 4 points calibration tool in control panel. It will add a secondary correction, which is good in some cases. And the corner accuracy will not be jeopardized by this 4 points calibration. The data file of this 4 points calibration seems to be "C:\Users\[your user name]\AppData\Roaming\WTablet\ISD_Tablet.dat Backup this file is also recommended.
Enjoy!
 
Search tags for this page

273 point calibration surface pro

calibrate surface pro pen
custom pen calibration surface
how to properly calibrate surface pro pen

pen calibration

surface pen calibration

surface pro 273 point calibration

surface pro 3 pen not working properly
surface pro pen calibration
surface pro pen calibration properly

Members online

No members online now.
Top