What's new

Pen Calibration Issue


New Member
Hi all,
I re-calibrated my pen tonight (according to this link: http://forum.xda-developers.com/showthread.php?t=2171198) and it worked really well. However I was messing around testing the calibration by drawing ruled lines across the screen (using the edge of my keyboard as a ruler) and I noticed some weird interaction between the keyboard and the pen (the pen wouldn't draw within roughly 10mm of where the keyboard touched the screen). Then a few moments later the pen wouldn't work at all, and OneNote said that the drivers didn't exist!

So I reinstalled the Wacom pen drivers, and now the calibration is SOOO far out, When my pen is in the bottom left corner of the screen, the cursor is about 3 inches higher... It's completely unusable, and I can't even re-calibrate it because the calibration tool doesn't recognise a pen touch on the lower calibration points.

Is there a way I can completely wipe all calibration data and go for a factory reset or something similar?

This is a huge problem, I can't live without my pen :-(


Active Member
The Surface keyboards are magnetic where you connect the keyboard to the tablet. You have, basically, applied a decently powerful magnet to your screen, assuming that you were using the flattest, stiffest part of the keyboard to draw your lines across the screen. I can't find a source on how Wacom tablets work but, given that it can detect a hovering pen, I'd guess that it uses some kind of electromagnetic field that interacts with the pen. A magnet would interfere with that and, I'd guess, could damage or alter the hardware.


New Member
Thanks for the reply, but for what it's worth I used the soft edge of the keyboard (it's longer, and still stiff enough to draw a straight line). so the magnetic latch wouldn't have been any closer to the screen then normal. But I can't be absolutely certain of this...

Any how, I tried numerous re-calibration techniques I found by googling, none of which worked. in the end I tried a system refresh and initially that didn't work either (no drivers were installed) then I reinstalled the Wacom drivers (side note: I can't seem to find the original windows drivers :-/) and now it's working as per normal again... PHEW!

Now I know that I can fix it, I'm keen to figure out why it screwed up in the first place... Seems completely bizarre...


Well-Known Member
You are not going to have straight lines. Wacom technology limitation.
Also, as you used the 278 point calibration, you don't allow for interpolation. Meaning that when you calibrate your pen, you pen, on every target needs to be pixel perfect hit, all 273 times, else the shift will show. You want less points, but too few leads to a bad calibration like the default one.

Also the 273 point calibration is generic for all tablets. It was never designed for the Surface Pro 1 and 2 in mind. You will notice for example, that you can't reach the right edge of the screen completely. So if you have a window maximized, you'll have a hard time using the scroll bar with the pen.

What I suggest, is using Surface Tweak Tool: http://www.surfaceforums.net/threads/surface-tweak-tool-for-surface-pro-2-release.8219/
- It has a 273 point calibration adapted for the Surface Pro 1 and 2, which will make it work edge to edge.
- Has a 80 point calibration designed for the Surface Pro 1 and 2 digitizer, which result in getting great results, with "only" 80 points, and not have to die with the 273 point one.


Super Moderator
Staff member
Could the device be seeing the keyboard as a palm and blocking the touch input in it's vicinity