What's new

Recovery Image (isn't available)


New Member
I've tried to download a recovery image for my SP3 i5 256GB
Download a recovery image for Microsoft Surface

Putting my serial in results in:
The recovery image for your device isn't available for download through this page. Please contact us for help

When I try to do that, it says I have to pay to contact support as the product is outside of warranty.

Any ideas? I have a Windows 10 USB (not a SP3 specific one). And when I did a clean install with it I can't run BitLocker and I've lost my WinRE option (although I kept the original 350MB & 200MB partitions in tact).

Does my SP3 really need a valid warranty to download a recovery image?!

Rob Cohen

New Member
@bmazloum - My warranty expired in November and I just tried to download the recovery image without a problem. It also worked for me a couple of weeks ago.

Something else is wrong? Signed into your MS account and have the device registered to that account? Are you trying to do this from outside the USA? Not sure if that would be a problem but it's the first thing that I can think of. I would try contacting MS support through that link if it's not one of these.

. Untitled1.png



Super Moderator
Staff member
Was your Surface purchased in the US? where are you now?

Is the time & date correct on your Surface... if the time is off you can get some strange failures...


Active Member
I have been getting the same "The recovery image for your device isn't available for download through this page. Please contact us for help" too for quite some time.
So because of seeing this post I tried again. First time it took several hour, downloaded about 2.6GB and then said it couldn't complete download. Retry did work. So I tried downloading it again and it did work. So maybe you just have to keep trying.


New Member
I purchased the SP3 when I was back home in the summer, I'm working overseas. Seems like this is working now, I managed to fix my partitions one by one and get BitLocker working after a lot of trial and error, but I'm downloading the image now for a quick solution in the future.

Thanks for the help.