What's new

Sleep crash


Active Member
Hi, I just checked event log and there seem to be "Critical - Kernel-Power", "Error - Bugcheck". I get sense there is no work around for sleep/crash issue?
Post your bugcheck image, or the text of it. Do you see anything unusual in Device Mangler?

I was thinking about hibernation but I thought it might not be good for SSD as it use SSD more.
Nonsense. The SSD should outlast the battery many times over.


New Member
I've been having this problem and finally decided to contact Surface support.

I have to say it was the best customer service I've probably ever had.

I went to the website and requested a call back. Within 20 seconds they called my phone.

It was clear they were fully aware of the issue. Their advice was firstly to shut down the computer, after it is fully off hold the volume up button down and then hold the power button down as well for 20 seconds. The Surface logo flashed, then a whole lot of text flashed then the screen went blank, then they said to keep holding both button for the full 20 seconds. Apparently this resets the firmware in some way.

They made it clear this is not a solution to the problem but can cause it to go away - in my case it is a day and a half and I have had no crash on resume from sleep issues.

They said they would call me back in 24 hours to see how the issue was going - they called exactly 24 hours later.

They said they were aware of the issue, as well as the issues of the surface turning back on when trying to hibernate and other battery related issues.

They said the January update only fixes the most severe issues but they expect new firmware in a couple of weeks to resolve the issues.

They offered to replace the surface immediately if that was my preferred option.


Try reinstalling Wireless driver. Go to Device manager, find Marvell wireless network controller under the Network adapters menu. Right click and uninstall the driver. Reboot the system. This will reinstall the driver. Mostly this should solve the problem. If not follow the second option.

Right click Marvell wireless network controller, go to properties, click on power management tab and uncheck Allow the computer to turn off this device to save power. This should definitely solve the problem. Hope this helps.


Active Member
The simple workaround for that is to connect the charger before trying to power on the SP2.

"simple" work around?

So I should carry my charger around with me and always sit by a power outlet every time I want to use my Surface?