What's new

Slow modern IE performance on Surface Pro

Ravynmagi

New Member
I just got a refurbished Surface Pro 1.

For some reason Modern IE is very slow at loading any and all websites apparently. At first I thought I was imaging it or being impatient. But after some testing I've noticed the following. First Modern IE on the Surface Pro is 2 to 3 times slow at loading websites than Modern IE on my Dell Venue 8 Pro (an 8 inch Baytrail tablet). Also desktop IE on the Surface will load webpages normally, as does Chrome on the desktop. So the problem seems to only be with Modern IE on the Surface Pro.

Has anyone see this, any ideas?

PS. All updates are installed, I've tried rebooting, and clearing the browser cache.
 
OP
R

Ravynmagi

New Member
Decided to do a refresh since I'm guessing nobody else has experienced this issue.

After the refresh, back on Windows 8.0. I noticed Modern IE is running much faster. Now I'm installing the updates, Windows 8.1, and Update 1. Will be curious to see if the problem returns after all these updates.
 

kristalsoldier

Well-Known Member
Decided to do a refresh since I'm guessing nobody else has experienced this issue.

After the refresh, back on Windows 8.0. I noticed Modern IE is running much faster. Now I'm installing the updates, Windows 8.1, and Update 1. Will be curious to see if the problem returns after all these updates.

Would it help to clear the cache?

Edit: Too late now! But if it happens in the future....
 
OP
R

Ravynmagi

New Member
I have Windows 8.1, Update 1, and all other updates installed after doing a reset on Windows yesterday. Been using it today, and browsing performance is much better and back to normal.

Dunno what was going on with Modern IE before, but the reset fixed whatever the problem was.

I should probably just get in the habit of doing a reset on all new devices I buy, seems like that'll save me a lot of time. :)
 

Staff online

Members online

Top