What's new

So what am I missing here??? really loud fan no more

nightpoison

New Member
Ok, so I've had the SP3 for roughly 2 months. from day one the fan would just spin and spin. When I say spin it sounded like white noise out out of a speaker. loud and annoying. Several people commenting on it at school as I'm taking notes.

Now I know the fan serves a purpose, keeps the surface cool. Well to the touch, top back right corner, it was HOT. It never shut down on me. but if I left my hand there for 10 secs it was VERY uncomfortable. So I started to do some research last night about the issue and came across a number of threads and articles. Most of the threads were dated by in august, nothing really current except on the MS forums.

I took some user advice and checked out task manager to see what was going on. Just sitting on the desk, with no programs or anything running I would feel the heat and hear the fan yelling at me. Well CPU was running at 20-30%, but the only process I could find was "Host process for windows tasks". With nothing running the CPU was running at 2.3-2.6GHz. Seemed weird, so i did some more reading and a number of people suggested disabling hyper-v. So I did and WOW, i MEAN WOW. night and day difference. to the touch its still warm, but warm in a light blanket during fall sort of way. The fan is no more. It kicks on after an hour of writing code for my software class, but very very low, and it shuts itself off after a few minutes. "Host process for windows tasks" is no longer running taking up 30% processing, but maybe 1 or 2% when nothing else is up and running. CPU is hovering around 1GHz, give or take .5.

What am I missing? What purpose does Hyper-V serve. Why doesn't it come disable from factory? Why isn't there a setting, other than disabling it through administrator command prompt. Don't get me wrong, I love my SP3, no regret getting it. Been disappointed with the sound and heat, but I've looked past it. But now with the way its running, wow.

I wonder how many returns and negative comments MS had when it was this simple to fix????? or is this not a fix?
 

GreyFox7

Super Moderator
Staff member
Actually Hyper-V is disabled by default.

If you installed Visual Studio it would have got enabled even if you never used it. I'm not aware of, although there might be, other apps that would enable it on install. Some people have enabled it to get different power settings besides the Balanced one but it should be disabled again afterwards if that was the purpose.

Glad you took the time to actually look for the problem and resolve it. Kudos to you!
 

jnjroach

Administrator
Staff member
Hyper-V is not activated by default, people recommended it because they didn't like that Microsoft had limited Power Profiles because of Connected Standby. If you were running on Hyper-V you needed to enable it.

Hyper-V is a Type 1 Hypervisor (hardware based) that allows you to run multiple Virtualized Workloads on the device. Typically for Dev or Test Work. Hyper-V is installed and loaded prior to the OS and is an abstration between the Host and Hardware.

I've not had the fan issues, but I also left the default power management alone.
 
OP
N

nightpoison

New Member
So why does Hyper-V cause the heat and fan to go batshit crazy?

I must have done something that enabled it, must have been done at day 1, cause the fan heat was from day 1. interesting.
 

jnjroach

Administrator
Staff member
So why does Hyper-V cause the heat and fan to go batshit crazy?

I must have done something that enabled it, must have been done at day 1, cause the fan heat was from day 1. interesting.
Here is a simplified view of what Hyper-V does when enabled on a device:

hyper-v-architecture.png

It is a Server Based Technology that has been shoe-horned into the mobile space for specific scenarios and is not fully optimized for the hardware, as I said earlier it is an abstraction layer above the Hardware and the OS now lives on top of the Hypervisor, so there is additional overhead.
 

bluegrass

Well-Known Member
He should find out how to and turn off Hyper-V. If there was an MS store to take it to, I would have taken it there in a NY second if the CPU was always being used 20% or more, the fan ran constantly, & it was always hot in the bottom upper right corner. Fortunately I have never heard my fan since I got my SP3.
 

olimjj

Active Member
To turn Hyper -V off, assuming you had not turned it on to begin with, in which case you would be aware of the procedure.
Do the following:
Open up Charms bar in the desktop by swiping in from the right
In the search Type in "Turn Windows features on or off "
Choose it
In the Windows features dialog box , uncheck Hyper-V
 
OP
N

nightpoison

New Member
ha, that was easier than going through the command prompt to turn it off. haha. not that the command prompt was all that hard. thanks.
 

bluegrass

Well-Known Member
I fell asleep. Why were you needing to shut the screen off. I have mine set for "do nothing" when you close the keyboard to the screen. That way if I want to listen to music without seeing the screen, I just flip the keyboard up.
 

Members online

Top