What's new

SP2 Starts, but Screen Stays Black (Doesn't Turn On)

CedricFP

New Member
Hi,

I have a problem with my SP2. It happened when trying to wake it up from sleep. The screen didn't turn on, and so I went through the hard reset process.

However, now the device is running (because I heard "narrator" from holding down volume down, and I can see it is connected to my network, and I do get a response from the Windows button) but the screen doesn't turn on. I can't get any response.

Does anybody know if this is a common issue and how to fix it?

Thanks.

Edit: However, the type cover 2 never lights up.
 
Last edited:

malberttoo

Well-Known Member
Hi,

I have a problem with my SP2. It happened when trying to wake it up from sleep. The screen didn't turn on, and so I went through the hard reset process.

However, now the device is running (because I heard "narrator" from holding down volume down, and I can see it is connected to my network, and I do get a response from the Windows button) but the screen doesn't turn on. I can't get any response.

Does anybody know if this is a common issue and how to fix it?

Thanks.

Edit: However, the type cover 2 never lights up.

Hi Cedric, welcome to the forum!

If it was me, I would plug it into an external monitor, using the mini DisplayPort connector. If you get video on your external monitor, then at least you could play around with disabling and/or updating video drivers, etc. If nothing else, do a clean install. If you still have issues after that then you almost certainly have a hardware issue, which means no repairing.

Let us know how it goes first though with the external monitor.

Hope it helps.
 
OP
C

CedricFP

New Member
Hi malberttoo,

Thanks for your reply.

I don't have a display port to dvi adapter and so can't test my monitor. I may get one to try.

Also, I should mention that at no time does the screen ever turn on -- I do not see the surface logo, etc. It remains black the entire time, and there are no flashes or flickers when doing the volume button hard reset method.

I should clarify: At no point does the screen ever turn on. However, after doing a hard reset my computer disappears from my network list, and upon rebooting, reappears. This at least suggests it is booting to the login screen, but the screen just isn't turning on.

Does this suggest to you a hardware issue with the screen?
 

ccstinger

New Member
Did you try unplugging the keyboard and plugging it back in? I once had the screen go black, hard booted it and everything. When I unplugged the keyboard it came back for some reason. Sounds funny, I know.
 

GoodBytes

Well-Known Member
Can you go in the UEFI?
Step 1: Shut down the system. (Press and hold for 4 sec the power button)
Step 2: Press and hold the volume-up button on your Surface.
Step 3: Press and release the power button on your Surface, then release the volume-up button.
Wait a few seconds and it should appear. Do you see it?
 
OP
C

CedricFP

New Member
Thanks for the reply, GoodBytes. Unfortunately no, there is no display. The screen is most certainly dead or disconnected.
 

GoodBytes

Well-Known Member
Thanks for the reply, GoodBytes. Unfortunately no, there is no display. The screen is most certainly dead or disconnected.
That really sucks.
I think I heard it's like 500$ to have it fixed. But, I would ask to be sure, and maybe look at repair shops.

Maybe Microsoft knows a trick or two to make it work again, despite out of warranty. Worth a try.
 

GreyFox7

Super Moderator
Staff member
Dang... Narrator works... maybe it's time for a donation to the blind. Battery life should be excellent. :D
 

Members online

Top