What's new

SP3 Dies after Restart

Ms.Dos

New Member
My SP3 was having some weird mouse pointer problems this morning (with my Logitech mouse). I decided to just restart the computer and see if that cleared up the problems. The machine cleanly shut down and then... never came back! I pressed the power button - nothing. I held down the power button for ten or fifteen seconds, and still no power. I set it aside for an hour and tried again - it still wouldn't come back. I had a dead tablet.

The power supply was at home. When I got home I plugged it in and tried the power button again, and it powered up. It still had a full charge, by the way.

Has anyone seen anything like this? I can't risk being on the road with a dead computer. My faith is shaken. I'm wondering if I should return it.
 

drolem

Active Member
This happened quite frequently with the earlier SPs, but I have yet to see it with the SP3. Just plug in a PS, or do a hard reset. You should always try the PS first, if available.

I also found that (with the SP1 & SP2) hibernating the machine avoids most of the sleep related issues.
 

DianeK

New Member
Happened to me yesterday. Same kind of thing. Had a full charge too. Mine went through some kind of update today. Hopefully, I won't see that issue again. Bugs happen with new devices so as long as updates come and fix those things I'm patient to wait through them. Usually, I wait 3 months before getting any new device for that reason, but I decided to take the plunge now.
 

Staff online

Members online

Top