What's new

SP3 problems CPU high load issue at idle Wifi limited / not connected


Active Member
Evidently something is happening. Have you tried reformatting your MicroSD?
Yep, tried it with multiple different mSD cards, including freshly formatted cards. Literally, we battled this issue for 8 months on the SP2 until Microsoft finally issued a firmware update end of May that was included in the June round of updates. Still shocked they let it return on the SP3.

Only somewhat reliable solution I've found at this point is simply don't insert an mSD card.... although, just like on the SP2, others are reporting this occurring without ever inserting a mSD card.

For further info, search the SP2 forum here or on answers.microsoft.com, tons of posts regarding this issue, but unfortunately no solutions. I can only hope Microsoft decides to fix it sooner than the 8 months it took them last time...

Unfortunately, most people don't even know it is occurring when it does, as extra heat and diminished battery life are the only signs unless you constantly run a process monitor (like I've learned to do!)


Active Member
But how do you explain that others do not have this issue?
LOL, how do you explain that SOME DO HAVE THIS ISSUE?!?

Browse this issue on the SP2, it shows up identically, and was finally acknowledged and fixed by Microsoft, yet many said it didn't show up on theirs. Microsoft fixed it in May/June updates.

See here for one example:

Here is MS's fix:

Another short and to the point thread:

There are plenty more on this topic, but like I said, the SP3 is new, and most users don't even know it is happening when it does, and it's not all the time.


Well-Known Member
Interesting. I understand your disappointment. Well, thanks for reporting it. If it was fixed before it will be fixed again. ;)


Active Member
Yea, I had that issue on our SP2 as well, it was frustrating as heck. The same SD card resides in my SP3, and *SO FAR* full restore has resolved the issue [knock on wood, it's only been about 36 hours]

Personally, I blame Realtek. They used to be really good about driver support/updates, but they haven't released anything in AGES...

/checks realtek website

Says 5/21/2014, but I'm almost POSITIVE R2.75 has been out a lot longer.