What's new

Solved SP4 Still Active In Sleep

leeshor

Well-Known Member
I'm gong to remind everyone in this thread that if you use the default sleep settings make certain all the apps are closed if you're having serious battery drain.
 

robertnd2

New Member
Seems like you should try turning off WIFI scanning during sleep and see if that does it for you. There is an option for that in the setting menu. Your culprit is much different than mine. I've got the Intel Graphics active over 90% of the time. Thanks for posting.
 

robertnd2

New Member
I'm gong to remind everyone in this thread that if you use the default sleep settings make certain all the apps are closed if you're having serious battery drain.
Thanks..not sure if I am understanding your message..doesn't closing all apps before putting the computer to sleep defeat the purpose of having sleep? Or..Are you suggesting that we try to see if it being cause by a certain APP that is left open?
 

leeshor

Well-Known Member
Thanks..not sure if I am understanding your message..doesn't closing all apps before putting the computer to sleep defeat the purpose of having sleep? Or..Are you suggesting that we try to see if it being cause by a certain APP that is left open?
No, it doesn't. If you were using hibernation it would. The default settings allow the Surface to perform background tasks while sleeping if WiFi is on. That means everything and anything that is open will run nearly as if it was awake. Of course a lot depends on what the app is doing. It's called Connected Standby, which is not the same sleep state you might have had in the past with a laptop.
 

robertnd2

New Member
Thanks..I understand. It just doesn't seem like connected standby is working too well if someone is losing 10-20% battery life in an hour or two when the computer is supposed to be in connected standby. If I have to shut down all of the open APPs to preserve battery life, seems like I might as well shut down the computer.
 

leeshor

Well-Known Member
Close. You can leave the apps open if you change a setting to turn off WiFi during sleep. With that set and a few other tuneups my battery loss is less than 1/2% per hour sleeping.
 
OP
P

Philtastic

Active Member
Seems like you should try turning off WIFI scanning during sleep and see if that does it for you. There is an option for that in the setting menu. Your culprit is much different than mine. I've got the Intel Graphics active over 90% of the time. Thanks for posting.
Close. You can leave the apps open if you change a setting to turn off WiFi during sleep. With that set and a few other tuneups my battery loss is less than 1/2% per hour sleeping.
For me, turning off both of the WiFi during sleep settings did nothing to help the battery drain during sleep.

I'm gong to remind everyone in this thread that if you use the default sleep settings make certain all the apps are closed if you're having serious battery drain.
Having to close all apps before putting the device to sleep really defeats the entire point of having a sleep mode. The only reason to even offer a sleep mode (rather than a "screen off" mode like you are describing) is so that you don't have to close all of your apps while saving battery life, as in, I want to resume where I was a couple minutes or hours from now while saving battery as I would on any other device, including previous Surface Pros. From what you've posted, you've customized, tweaked, and removed apps from your SP4 to get great battery: awesome for you. I and many other users, however, just want the thing to work well out of the box as any good consumer product should without having to troubleshoot, research workarounds, and edit registries.
 
OP
P

Philtastic

Active Member
Yesterday, I did an exchange because the keyboard port was dying, installed a lot of my usual programs, and then left it in sleep overnight with the Facebook app and Edge still open. Over 8 hours, it only used 4% (or 0.5% per hour) which is right on what I expect out of sleep mode. This is with WiFi connection during sleep left on.

I don't know if this is because of the new unit or because of the updates from yesterday but I'm glad that it seems fixed now. Will report more as I install more programs and leave it in sleep overnight.
 

macmee

Active Member
Mine is arriving today/tomorrow, here is my pre-emptive strike against bad battery:

1. disable windows hello, whatever the heck it is it sounds like it's causing the battery disaster above?
2. disable distributed windows update hosting
3. not turning off wifi in sleep unless I get this battery issue
4. turn all apps off from running in the background

if I face the same issue as you guys I'll run a battery test on my SP3 and Sp4 and post the diff. Honestly nobody should be surprised by these issues because pretty much these identical bugs happened when the SP3 and SP2 both came out and I'm assuming SP1 as well.
 
Search tags for this page

sp4 sleepstudy

surface pro 4 active cpu sleep
surface wireless active during sleep

Members online

No members online now.
Top