What's new

Solved SP4 stuck at preparing Windows and won't turn off


New Member
[Edit] Literally two minutes after posting this my Surface decided it took long enough and it booted up again. Still have no idea what took it so long, but for next time I'll know to be very, veeeery patient, hahaha. It has now gone back to being the sunshine it always is. I really love this device! Sorry for wasting everyone's time, in case someone was already reading my long story! And have a nice day. ^^


I've had my Surface Pro 4 for a while now and it usually works just fine, but today Windows has decided to give me a major headache. I scanned my device with Malwarebytes because that's just something I do every once in a while. It didn't find much special, except for a few WinYahoo things and stuff that it wanted to delete. I let it and it said it had to restart my computer now, so I let it do that too. Usually on my other computers this has never given me any trouble, but the SP4 has now decided to get stuck on the 'preparing Windows please do not turn off the computer' screen. It's usually really fast while doing this and right now it has been on that screen for about an hour. Even though the circle is spinning, I'm afraid not much is happening and it's just stuck.

I've already tried to be stubborn about it and turn it off after all - it simply won't turn off. The screen will flicker to black for only a split second and then the same message appears right away again. So there's really no way for me to get my SP4 to work, but there's also no way for me to turn it off and reboot it. Not until the battery runs out at least, and I'm out of luck, because it was fully charged before it went into the reboot.

Should I wait longer? Give it a little pat on the back with a hammer? Should I let the battery run out? I have no idea what's suddenly going on with my device (and I also don't really know if it's even the device causing the problem, because the device has always worked flawlessly? This seems like a Windows-problem to me?). If it had been my laptop, I would've just taken the battery out for a second or something, but with the SP4 there's literally nothing you can do, it seems.

Any advice would be much appreciated. Right now I'm just hoping the battery runs out sooner rather than later so I can turn it back on and it will behave again. I have a laptop and a desktop for backup, but still, I'd rather just have my SP4 work the way it should, I already miss it.

Thanks for reading and even more so for replying!
Last edited:


New Member
Press the volume down and the power button both at the same time for 30 seconds. The system will reboot.

Sent from my ONEPLUS A3003 using Tapatalk