What's new

Solved Surface Dock Ethernet Drivers


New Member
I received a replacement Surface Book from Microsoft yesterday, and I'm trying to do a bare-metal restore using Windows Server 2012R2 Essentials. In order to perform a restore, I must have a wired connection to connect to the server. The Essentials Restore boots from a USB drive and gives you a chance to install drivers for the network. I used the powershell command 'export-windowsdrivers' to export out the drivers, but the dock wired drivers do not seem to be located or recognized by the wizard.

I've searched to see if I can find the drivers themselves, but only found the generic Surface Book zip file that only includes Bluetooth and Wireless network drivers. Nothing in regards to the dock Ethernet drivers.

Curious if anyone else has had a successful Surface restore from Win 2012R2 Essentials backup, or knows where one might find the drivers.
I searched High and Low and found drivers and yet it still wouldn't work . I cannot get the Surface Book dock Ethernet to work in a restore to my WS2012E server. I even went and bought the USB to Ethernet from Microsoft and that didn't work either. I finally went to best buy and bought this one for restores..

j5 create - USB 3.0-to-Gigabit Ethernet Adapter - Gray

I can confirm that this one will do the trick.

I am so disappointed in MS not supporting their hardware and making it a seamless experience
Yeah, I also tried the Microsoft USB Ethernet adapter that I had from my previous SP3, turns out it is exactly the same hardware as what is in the Surface Dock with the same driver (Model 1663). My next step was to go buy a generic USB to Ethernet from Best Buy. I'm happy to know I was on the right track, and that I wasn't missing something simple. Greatly appreciate your response!
Just as a follow-up, bought the j5 USB Ethernet adapter as you recommended. It worked like a champ, didn't even have to tell it where to find drivers as they were in the core drivers list. Thanks for your help!
I agree with that. One other question.. After your restore completed, did the SB boot directly? Or did you have to set bootrec MBR and such. I restored but getting a 0xc00000e blue screen (boot inaccessible), which I'm planning to fix with the repair wizard.
Ok, good to know. I'll try the restore again, maybe something happened with this one.
Just as a follow-up, in case anyone else runs into this.

After the Server 2012R2 Essentials restore, the PC would not boot, but blue screen with error 0xc000000e.

To fix, I used a Windows 10 bootable USB drive, went to the repair settings, advanced, command prompt and entered the following:

#1 - My drive did not have a drive letter assigned.
select disk 0 (or 'list disk' if you are not sure which disk)
list partitions (look for your main drive)
select partition 2
assign letter=d (c was already taken by the boot thumb drive)

#2 - Fix MBR/boot and Rebuild BCD
bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd (press 'Y' to accept)

Exit out of the command prompt, reboot the SB and all was happy.
Dzik...the restore wizard that boots from the WS2012E does not support the Ethernet even with the drivers. That is what the whole topic is. Both of us have tried it with all the drivers, docking station, and usb to Ethernet.
It does guys! I restored my replacement Surface Book from WS2012ER2 backup yesterday. Just got to use Surface Pro 3 Ethernet drivers. Neither of you mentioned using those.