What's new

Surface Laptop 4 Installation Stuck at 31% - Error: No Changes Were Made


New Member
I'm experiencing a frustrating issue with my Surface Laptop 4 (Ryzen, 8GB RAM, 256GB SSD) during the installation of Windows. I have tried both Windows 10 and Windows 11, but I keep encountering the same problem.

During the installation process, everything starts smoothly, but when it reaches 31%, it stops and gives me the error message: "There was a problem resetting your PC. No changes were made."

Here is what I've tried so far:

  1. Created a new USB installation media using the Media Creation Tool from Microsoft's official site.
  2. Configured the BIOS/UEFI settings to boot from the USB and temporarily disabled Secure Boot.
  3. Ran diskpart to clean and repartition the SSD.
  4. Checked the SSD and RAM for errors using built-in diagnostics and third-party tools like MemTest86 and CrystalDiskInfo.
Despite these efforts, the installation still fails at the same point. Has anyone else experienced this issue or have any suggestions on how to resolve it? Any help would be greatly appreciated.

Thank you!