What's new

Surface now hibernates instead of sleeping.

Nick K

New Member
Since the recent firmware update, I have found that my Surface Pro 2 no longer goes to sleep when I close my Type Cover 2 or press the power/lock button; it instead appears to hibernate. Before the update, when I closed my Type Cover 2 and then came back and opened it later on, the Surface would wake instantly to the lockscreen. However now when I open the Type Cover 2, nothing happens, I actually have to press the power button which brings up the Surface logo for a few seconds before taking me to the lockscreen as if it is coming out of hibernation instead of sleep. My programs and documents are all still pen like they were beforehand, however this short wait is rather annoying when I'm so used to a quick wake when I just open the cover. I have checked my power settings and it is still set to sleep when I close the lid, not hibernate, yet it still appears to hibernate instead of sleeping.

Is anybody else experience this issue, and does anyone have a fix?
 

jrapdx

Member
Since the recent firmware update, I have found that my Surface Pro 2 no longer goes to sleep when I close my Type Cover 2 or press the power/lock button; it instead appears to hibernate. Before the update, when I closed my Type Cover 2 and then came back and opened it later on, the Surface would wake instantly to the lockscreen. However now when I open the Type Cover 2, nothing happens, I actually have to press the power button which brings up the Surface logo for a few seconds before taking me to the lockscreen as if it is coming out of hibernation instead of sleep. My programs and documents are all still pen like they were beforehand, however this short wait is rather annoying when I'm so used to a quick wake when I just open the cover. I have checked my power settings and it is still set to sleep when I close the lid, not hibernate, yet it still appears to hibernate instead of sleeping.

Is anybody else experience this issue, and does anyone have a fix?

I think lots of SP2 users report problems with sleep/hibernation. I've had similar-sounding issues, but not sure exactly the same as what you describe.

I've changed the settings often enough it's hard to remember various combinations in effect at a particular point. I know you said you checked the settings, but I'd go through it again and thoroughly to make sure it's set up correctly (or the way I want it anyway).

Make sure the on-power and on-battery settings for each power plan are properly set, especially the sleep/hibernate times. If you prefer, you can disable hibernation, at least as a test to help clarify the problem.

Systematically reviewing all these settings is a tedious chore, but I've found it helps me to know what's going on in regard to sleep/hibernate behavior of my SP2.
 

Rvacha

Member
it is best not to assume you are hibernating - you could be crashing. Look in the event viewer for "the last shutdown was unexpected" (or something like that). Some SP2s including both I've owned crash when trying to transition from sleep to hibernate
 

grumpy

Active Member
Immediately after the last update my SP2 would hibernate instead of sleep when the power button was pressed. I changed the power button action (in the advanced power settings) to "do nothing", clicked apply and then changed it back to "sleep" and clicked apply again. Now it is sleeping fine.
 
OP
N

Nick K

New Member
Immediately after the last update my SP2 would hibernate instead of sleep when the power button was pressed. I changed the power button action (in the advanced power settings) to "do nothing", clicked apply and then changed it back to "sleep" and clicked apply again. Now it is sleeping fine.

Yep this fixed it, thanks!
 

macmee

Active Member
Have they fixed the sleep crash bug? I hope so I've always had that one.

Also has anyone else not gotten the update yet too?
 

Nismode

New Member
Immediately after the last update my SP2 would hibernate instead of sleep when the power button was pressed. I changed the power button action (in the advanced power settings) to "do nothing", clicked apply and then changed it back to "sleep" and clicked apply again. Now it is sleeping fine.

Yep this fixed it, thanks!

Seems to have done a fix for me but we'll see if it persists...
 

Members online

No members online now.
Top