What's new

Surface pro 2 fails to start after trying to restore


New Member

Last nigh i wanted to restore my Surface pro 2(make a clean install and remove all files). But unfortunately it failed.. :( And now everytime it try to start the surface logo comes up but then the screen goes black and stays that way untill i turn it off.

Info: Windows 10 was installed when i tried to do the reset. Original when i bought it was winows 8.1.

I have tried the following.
1. Holding down the powerbutton and volume button for 30sek.
No change
2. swiping on the corver of the screen to se if i can get any settings.
It did nothing
3. I held down the volume up button and klick on power. This got me to a settings software where i could shose different options(like, restore, troubleshoot, and many more)
I tries all the different options. I even tried to use a USB media recovery(win 8.1) but it just reboots and no install starts.
4. I tried to how volume down + power. Got to a blacks creen where i go the following option.
  • Trusted Platform Module (TPM)
  • Secure Boot Control
  • Delete All Secure Boot keys
  • Install Default Secure Boot Keys
I was not sure what i should do here but i tried to disable "secure boot control" and also tried to "install default secure boot keys".
Did nothing except the screen turned red when i disabled the "secure boot control"

I feel that i have tried everyting that i foud info about.

I really would appreciate help if you think you have any good tips.

Thank you