What's new

Surface Pro 4 firmware/hardware updates 4/19/2016

WaVeS

New Member
Like many others, I also got the BSOD....it rebooted, seems to have installed most of the files, but left one uninstalled: driver update for Intel(R) Control Logic. Still won't install it.
I did find the fix. There is a post on reddit and others.

Not my work, I just found this.
"this workaround was posted on reddit (and fixed the issue for me!):

  • Open the setupapi.dev.log log file from c:\windows\inf.
  • Find the error "Failed to install device instance".
  • Above this error it will say which inf file caused the issue. In my case oem90.inf
  • Run "pnputil -d oem90.inf" from an elevated command prompt
  • Re-run windows update and install
source: a botaload of new drivers incoming • /r/Surface and Surface Book Update Failed – Intel Control Logic – 0x800f0203 "
 

cmergel

Member
Yes, the reddit steps worked for me but it was the oem125.inf file that failed.

Rant Begin...
Sigh....
Hacks to get updates to install. Yes for the win, no fail...
Did they test this on like one machine and then release it. :)
Rant Over...
 

Iceman22

New Member
The update seems to "fix the not wake from sleep issue" on my SP4. However there is still one problem left I can't figure out. It won't enter sleep mode automatically, If I enter go to sleep after 1 minute it fails to do so, I have to close the cover or press the power button. I checked the surface diagnostic tool for updates and it updated watchdog timer driver but it didn't make any difference. It might be something to do with the insider preview build, I'm in the slow ring.
 
Last edited:

ichfarte

New Member
I encountered a BSOD and then black screen (unlit keyboard) after installing the update.

Power button had no effect.

Did a hard reset.

System finally opened to BIOS (may be the wrong term). I clicked exit.

My SP4 then rebooted without a problem.

Same, I actually made an account just to warn others. I let it install with no interference from me while I ate breakfast, then it restarted...and never came back. Power button was ineffective, almost all the different hard reboots were ineffective. Eventually I had to try the 30 second power button, followed by 15 seconds of volume buttons reboot, which eventually worked and brought me to the BIOS.

So far, not amazingly impressed by this update.
 

Teclini

New Member
After the 3 Firmware Update SP4 Pro i7 shutdown. Can not start it now. Hold the Power Button for 10 sec have no effect. :-(
SP4 ist dead .......


edit:
OK Power Button and Volume Down open the Bios After Restart System is running

edit 2:
After new reboot firmware update works with reboot.
 
Last edited:

sjrixon

New Member
I've not had an issue installing this update. Still can't get 2 external monitors working on my dock though!
 

Moskix

New Member
I updated my surface pro 4 i7 to the latest firmware. Now the fan keeps running even the device itself is cold. The fan will start to run even when surface pro just starts up with the 'Surface' logo showing. Any idea?
 

Members online

Top