What's new

[Surface Pro] Solution forType/Touch Cover + Windows Button + Pen NOT WORKING

ksantoso

New Member
Suddenly got it this morning. It was pretty frustrating:
1. type cover was undetectable
2. pen was undetectable
3. windows capacitive button had haptic feedback but didn't do anything

I went to a MS store and they tried my surface with different covers (didnt work), tried my cover on different surfaces (worked), so something was wrong with my surface.
They told me to send my unit to MS to get a replacement but thankfully I ignored them.

Try this first before you decide to send your unit:
1. unplug any usb devices
2. open up device manager
3. under "Human Interface Devices", uninstall "Surface Type Cover Firmware Update Device" and "Type Cover Trackpad Settings"
4. go to charms>settings>shut down
5. power it back on
6. connect the cover to surface and the drivers should re-install automatically in a few seconds.

It did the trick at least for me, cover + pen + winbutton are working again. Hope this helps.
 

Members online

No members online now.
Top