What's new

Type Covers No Longer Working


New Member
Hi All,

Hoping someone can help me;

I have a SP3 Pro, I was using it the otherday and put it into sleep by flipping the type cover up. When I returned and turned it back on the "Rotation Lock" was enabled and the Type Cover was not working. I disabled Rotation Lock but the type cover never came back to life.

It is not recognized in devices, I have tried the following:

1. Cleaning the cover and connectors - No joy
2. Booting into UEFI, it does not work there either
3. Trying another type cover this also did not work
4. Trying my type cover on another laptop, which did work fine
5. a System "Reset"
6. "Surface Diagnostic" which came up with nothing

Anyone got anything else I could try? This is super annoying as the rest of the surface seems to work fine.

Any help much appreciated


Staff member
Shutdown the machine completely, then hold the volume rocker up, now while continuing to press the volume rocker power on the device, let go when the Surface Logo appears,.

From the UEFI screen - exit and restart, reattach the Type Cover. That is how when I still had a SP3 I was able to fix this. If it still doesn't work it is possible that the USB Hub via the Surface Type Connector has failed.