What's new

Surface Pro won't connect faster then 5.5mbps to Linksys WRT320N


New Member
Tried two surface pro's - same problem

Router is known good for 4-5 years, has no issues with any other devices

Firmware: DD-WRT v24-sp2 (03/25/13) vpn
(just updated again, same problem before)

Here is what happens:

^^ Notice the Wireless speed is 5.5mbps. It's always like that when the surface is transferring data

Tried: every possible setting under wireless, n only, 5ghz, g only, etc. Tried no encryption. reflashing router, rebooting router, factory reset on surface pro, windows 8.1, different drivers for wifi adaptor, rebooting

Nothing works. Any ideas?


New Member
So, your other devices all connect wirelessly and their upload speed is greater than 5.5Mbps? And you only have whichever system you are checking powered on during the time you're running your tests? The limitation you're showing could be due to network traffic or a cap due to network congestion too. What do the wireless speeds of your other devices look like?


New Member
Yes, of course, all of my devices work fine. Typical connections speed for my cell phone is ~150mbit, macbook pro the same.

The surface is always connected at 5.5, capped upload and download.

I have tried turning off all devices in the house and the issue still occurs.


New Member
I just flashed the factory firmware - released all the way back in 2011.

It totally fixed the problem on the surface.

Ive never had a problem with dd-wrt with another device, and I have lost OpenVPN which I used.

Not sure what I am going to do.


Staff member
There have been other users who have had issues with the DD-WRT Router Firmware on the Surfaces, one issue around Open Source Software is if they don't have access to the new technology they can't update their wares to support. The Marvell Chipset is fairly new and predominantly found on phones.