What's new

System Interrupts high CPU - audio driver fault?


New Member
I've been getting annoyed with my Windows 10 SP3 running hot due to high CPU usage so today started to delve into it. This doesn't happen all the time, something triggers it and it stays high and hot until I reboot.

I decided to stop numerous services one by one using the Services app, selecting non-essential looking services (no science here - just guesswork), and stopping them while also running Resource Monitor to see what, if any, difference it would make to the CPU use.

System Interrupts was shown in Resource monitor constantly using 18-23% CPU for the previous hour. I had closed all running programs (Outlook, Chrome etc etc) and left everything to sit for an hour to stabilise before I started stopping services.

After stopping a bunch of services with no effect at all, I stopped Windows Audio. CPU use immediately dropped to 2%, but then rose back up again to 20% after a few seconds. Strange. I then stopped Windows Audio Endpoint Builder and the same thing happened - CPU dropped to 2% again. Interesting.

Going into Device Manager > Sound, video and game controllers > Realtek High Definition Audio, I disabled the driver. CPU (specifically System Interrupts) immediately dropped to 2% then back up to 20% after 2 secs. I then enabled the driver again, and CPU immediately dropped back to 2%, and then up to 20% after 30 secs or so.

So it looks like there's something very screwy going on with the audio driver. The driver version I have is 30/6/2015

It's odd that disabling then enabling the driver causes the CPU to drop to "normal" levels, but then it shoots back up again after a little while. I'd have thought disabling it would cause it to stay permanently at low levels. I suspect that there's something which is accessing the audio driver which is causing the problem, rather than the driver itself as I can't see how it could use CPU if it was disabled (though I'm happy to be enlightened on this). However, fiddling with the driver definitely has a dramatic, though temporary, effect on CPU use.

A reboot of the machine puts everything back to normal. I've yet to figure out what the trigger for the high CPU usage is. I didn't have this issue prior to Win10.
Last edited:
This has been a lingering problem for a long time.
see ref in 2008 High CPU - Hardware Interrupts
It's not an uncommon one although not the only cause either...
searching the internet will give you plenty of cases to review.
but is it a hardware triggered problem or a software one... or both/either.
I recall a similar problem with my SP3 when I first got it (early adopter) and after a while it went away following one of the many firmware updates. I suspect that some bug fixes have been omitted from the latest driver release that had been previously fixed - a common problem with shoddy version control.
I have a Surface Pro 3 and I also have this problem. I tried disabling and enabling all audio related drivers and I found the culprit: High Definition Audio from Microsoft. See the pictures below before and after disabling the driver. If the driver is disabled, the problem disappears but there is no sound. I hope that this put pressure on MS to correct the driver.
More follow up....

I think I solved the problem in my system (Surface Pro 3, i7, Windows 10, microSD card inserted)

I physically removed my microSD card and this WORKED.

I inserted again the microSD card to try further options.

I went to the site realtek.com.tw, downloaded the audio (128,413KB) and USB Card Reader (13,972KB) drivers, installed them. Doesn't work.

I went to the Device Manager, and tried enable/disable/reinstall several devices related to audio/SD card/USB. Doesn't work.

The last thing I did, and that SOLVED the problem, is to uninstall the USB driver and reinstall it:
Go to Device Manager/Universal Serial Bus controllers/Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)/Uninstall
This will disable the mouse, keyboard and all USB related devices.
Go to Device Manager/YourComputerName/Touch with finger for a few seconds/Scan for Hardware Changes.
Wait until Windows 10 finds all your devices again.

This procedure is somewhat risky because input peripherals will stop working, but the touch screen keeps working in Surface Pro 3.
I don't know if this procedure requires the installation of the Realtek drivers; if you wish, you can try first without installing them. Their huge size indicates poor quality in my opinion.
If you try this procedure, let us know your system and if it works.
Last edited:
More follow up...

One day later the System interrupts high CPU use started again. :-(

I was sure that I had solved the problem earlier, so I tried again...

Lots of disable/enable/reinstall devices in the Device Manager. Doesn't work.

Lots of uncheck Allow the computer to turn off this device to save power. Doesn't work.

I found an easier procedure that substitute the one in the previous post: reinstall the USB Controller with itself:
Device Manager/Universal Serial Bus controllers/Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)/Update driver software.../Browse my computer/Let me pick/USB xHCI Compliant Host Controller/Next/Close

Then I remembered that I reenabled Realtek startup applications in Task Manager/Startup.
I think that they were quietly reinstalling the Realtek device drivers.
I uninstalled the Realtek bloatware: Control Panel/Programs and Features/Realtek audio and card reader/Uninstall.

This apparently solved the problem... but...
Later the problem returned.
I noticed an uninstalled Realtek driver lurking. I installed the Realtek driver and then uninstalled with delete:
Device Manager/Sound, video and game controllers/High Definition Audio Device/Update Driver Software.../Browse my computer/Let me pick/Realtek/Next
Device Manager/Sound, video and game controllers/Realtek High Definition Audio Device/Uninstall and delete.

So, don't install the Realtek drivers in Surface Pro 3.

Now all audio and USB drivers in Device Manager are from Microsoft, all with date 10/29/2015. There are no Realtek drivers, not even uninstalled.

Now I have sounds, microSD card inserted and hibernate working ok. Let's see for how long.... :)
Last edited:
It didn't take long for the bug ressurrect.
The Windows Update reinstalled the Realtek drivers.

I uninstalled everything related to Realtek in Device Manager:
Device Manager/View/Show hidden devices
Device Manager/Audio inputs and outputs/*Realtek*/Uninstall and delete
Device Manager/Sound, video and game controllers/*Realtek*/Uninstall and delete
Device Manager/Universal Serial Bus controllers/*Realtek*/Uninstall and delete

Reinstall the USB Controller over itself:
Device Manager/Universal Serial Bus controllers/Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)/Update driver software.../Browse my computer/Let me pick/USB xHCI Compliant Host Controller/Next/Close

Then I disabled the update of devices:
Control Panel/System/Advanced System Settings/Hardware/Device Installation Settings/No

Now let's wait for the next ressurrection from Jason...
Last edited:
The Jason bug resurrected again.
Windows Update reinstalled the buggy Realtek drivers.
This means that Control Panel/System/Advanced System Settings/Hardware/Device Installation Settings/No doesn't work.
I will try other ways to prevent installation of device drivers and then I will post my findings.