What's new

The driver detected a controller error on \Device\Harddisk1\DRx


New Member
Hello everyone, been reading the forums here since I got my SP3 a few years ago, but now need to delurk to get some advice.

I sold my SP3 and splashed out on the base i5 model of Surface Book from John Lewis, picked it up while the dock was being given away for free, and luckily also managed to get 10% off when the price dropped for a few days.

I'm fully aware that the SB is not perfect (and I'm sure the John Lewis 3 year warranty may come in to play here), but I just love the A4 sized screen that I use at night to read some mags and comics while not disturbing the wife! Although I have to save I watched the reveal presentation hoping that a 14" SP3 type model would be revealed to no avail...

So I've decided to ditch my trusty Asus P1801 i7 (you'll see my obsession with big tablet screens to function as expensive comic readers, however the P1801 DPI wasn't all that great and that's where the SP3 came in). Now I had this configured up just fine and everything was working great.

Now, amongst other problems that I've already sorted out, I'm having problems with powered external hard drive docking stations I was using fine, and that work fine on the other computers/tablets we have.

"The driver detected a controller error on \Device\Harddisk1\DRx"

This is the error I'm getting in the event log every now and again and it is doing my head in!!! I can hear the hard drive plugged in to either of my docking stations make a funny noise as if the head is being momentarily parked, this results in the controller error message in event viewer.

I have the SB fully updated, the dock is also updated - I've ran troubleshooters as advised elsewhere. Also I've turned off the annoyance that is selective suspend - I prefer to hibernate - and I've been in device manager and turned off power management on the usb devices.

This has managed to get the issue down to infrequent from what was every minute, and before running the troubleshooter Windows was just mounting and ejecting the drives/docking station every few seconds.

I know there's nothing wrong with the docking stations or the hard drives attached.

But this is making working on it very difficult. I ran a full chkdsk on a drive yesterday and NOT ONCE did this issue occur while the drive was fully in use so it must be related to idling somehow.

Now, I'm getting this error when copying some files to the drive:

An error was detected on device \Device\Harddisk2\DR41 during a paging operation

Any ideas on this problem? I love my SB as it is one of a kind at the moment, but this is possibly a deal breaker for me. Is the Surface Dock just a piece of, ahem, rubbish?
Last edited:


New Member
OK, I think I've solved it myself.

I started looking into powered USB hubs and realised my monitor has it built in.

Problem appears to be solved, but why why why?

The external drive already has its own power supply.

So anyway, I now have my powered USB 3 Dual SATA docking station plugged into the USB 3 hub on the monitor and then the monitor USB is plugged into the Surface Dock.

I'm sure there is a perfectly reasonable technical reason for this, but this was my main annoyance (although there are a few more I have, mostly relating to using an external monitor and windows being crazily resized every time I turn it on and off, not to mention the sound disappearing until I power cycle the monitor...but that's for another thread!).


New Member
Nope, back to the same now even plugged in to a wired hub, it seems to be when I have 2 hard drives in the USB dock - what is up with this?

I just keep hearing the mount/dismount noise but the drives never show up.

Is this to do with USB resources on the SB? - if so is this fixable because as of now there's no way this can replace a desktop if it can't run a powered USB SATA dual docking station!

edit: Hmm, just plugged a USB pen drive in and the turned on the SATA dock to copy some stuff over and it started freaking out again, not picking up the dock...

However, restarted the SB with both dock and pen drive attached and it found them both no problem, WTF Microsoft?!
Last edited: