What's new

Two keys stopped working on Type cover


New Member
Hi All
I use a type cover (the first generation) with my Surface RT. It worked fine for 10 months, then suddenly two keys stopped working - namely, "g" and "h".
There seems to be lots of threads about the whole keyboard not working, but my issue is just these two keys. I tried restarting the Surface, refreshing, cleaning contacts etc - nothing helped. It seems it is a hardware problem?

I'm thinking of yanking out those two keys to see maybe there is some dust/dirt underneath that needs to be cleaned. Any tips how to do that without breaking the keys? Also, is there anything else I can try to bring these two keys back to life?

I think the keyboard has a 1-year warranty, but I've lost my receipt, doh.

Thanks for any suggestions!
OK, I just pulled those two keys out with a fingernail. No dust or dirt there, looks normal. So probably some connection or wiring went bust. Any suggestions?
I had the same problem a while back, though in my case I suspected that liquid or debris (I'm sloppy and read my morning news and e-mail as I drink my tea and have breakfast). I cleaned it and tried other things but to no avail. Eventually I wound up buying a new one. That hurt at the time spending that much for an tablet-wise old unit, but the upside is that the newer type covers light up so I'm actually kind of glad. That had always been an annoyance.