What's new

Type Keyboard and Windows Button Packed in


New Member
Ok, typical... been using the surface endlessly for a couple of months and thought it would be well up to the task as an emergency dev machine while travelling. A week into Europe my Type Keyboard and Windows key (hardware one on Pro) have both packed in...

First the keyboard, dead, nothing. Tried removing, restarting, etc. No joy.

The windows key vibrates but does nothing.

I have a feeling this all happened the same time, and I am pretty sure no updates have installed as I have had little connectivity.

Also, and this is infuriating, the screen keyboard won't stay open in this editor, until I worked out you can lock it in the charms menu.

So - the question is, can anyone help? Thought about a reset but I don't have the recovery partition with me or installation media for my crucial dev apps while I am on the road. a week till I am back in the UK and I don't fancy any emergency dev work on the touch keyboard and 1/2 screen!


You can always try the following "Battery Out Reset" procedure to see if that helps:

1) Hold the power button for 20 seconds while holding the volume down button
2) Release, then hold the power button for 5 seconds again, with the volume down button pressed.
Thanks - been a couple of days without connectivity, turned it on and it's all working again. Weird.

Next time will remember the above - thanks.

Ironically during my limited time of connectivity got through the MS and was told they were putting a new keyboard in the post. Don't know if this means they know of a hardware issue or not?