What's new

USB 2.0 devises are not recognized on Surface Pro

alexovich777

New Member
Hi all,

I have recently bought my MS Surface Pro from ebay. I have refreshed the OS and have run an update on it.

It does not seem to recognize USB 2 devices. I don't have many devises to test it on but both my 4gb USB sticks and USB hard drive is not being recognized. By that I mean that Surface not even giving any error messages and the LED on the USB stick is not flashing.

I have the Lexar USB 3 card reader which works with it without any issues.

I have tried to follow the advice from here USB 3.0 drivers not working on Surface Pro | Microsoft Surface tablet but when I have tried to install the driver I have got message: "This computer does not meet the minimum requirements for installing the software".
 

starLog

New Member
You probably will need to jailbreak it to allow for the driver to be loaded.

Jailbreak....how dumb was that answer. Forgot it was a pro. My bad
 
Last edited:

CrippsCorner

Well-Known Member
Jailbreak a Surface Pro!? That doesn't even make sense to me...

I know it's not a good fix but maybe you could try running this USB 2.0 devices through a USB 3.0 hub?
 

EuroKnuter

New Member
I have a wide array of peripherals attached that are USB 2 and 3, with a 3.0 hub and a 2.0 hub as well. The only issue I've had was with my Guitar Rig Kontrol unit, which lost audio quality due to the increased power flowing through the USB 3 port (I've since updated that devices driver, and all is well). I assume you've checked to make sure both devices work on another computer... so my only thought would be the difference in power is not being recognized. You may be better off with a USB 2 hub than 3... dunno, just guessing and trying to offer up some idea that may lead you to a solution eventually. Good luck! =)
 
OP
A

alexovich777

New Member
Thanks for advices using HUB. I'm almost sure it will work but I'm looking for more elegant solution. It is tablet after all.
 
OP
A

alexovich777

New Member
I FIXED IT!!! I FIXED IT!!! I FIXED IT!!!

Some idiot that owned the Surface before me bend the USB 2 pins inside the connector. As the USB 3 uses different set of pins it was working without problems.

Today I spent over an hour trying to straighten them and in the end it works.

I would help if Microsoft would introduce more than one USB connector on future models

:)))
 

AlperOZCAN

New Member
Hello alexovich777,

I'm having "exactly" the same error. (Since May 2013) Only USB 3.0 works.
But i think, no one have experienced same, until I saw your message today (Your message was from July, wow. I'm searching for sometimes, but never seen it).

Surface online support looks the error from remotely, but they don't gave an useful answer because of the problem's size. And they want me bring Surface back to them for warranty. But, I could not yet.

Can you explain more briefly, what have you done for USB socket?
I think I have same issue for usb port. Was there a pin problem, or was there a only dust, what do you think?
 

beman39

New Member
Well from reading his post, it was a bent pin, so you can rule out dust, maybe he can post how he fixed his Bent pins OR perhaps try looking on Google? Wealth of info on there. :smile:
 
Search tags for this page
microsoft surface not recognizing usb
surface pro 2 set usb to usb 2
surface pro 2 usb drive not recognized

surface pro 2 usb not working

surface pro 3 usb port not working

surface pro not recognizing usb devices
surface pro usb device not recognized

surface pro usb not working

surface pro usb port not working

usb not recognized surface pro

Members online

Top