What's new

Solved USB Port Stopped Working


New Member
Received a new Surface Pro3 2 with Windows 8.1 two weeks ago and have been transferring all my previous Windows7 laptop data into it and re-installing all previously used programs. Everything was working, including the right-side USB port, and all the ports on the docking station. This morning (Tuesday Sept 9th), I disconnected from the docking station (which had external keyboard,speakers, mouse, and external DVI screen), and moved to another office location. Using just the Surface (WITHOUT the docking station), I then proceeded to attach the same USB mouse (that had been on the docking station and had also previously worked in the right-side USB port) - the port didn't recognize the mouse. In fact it didn't recognize ANYTHING - not an even external keyboard (which had worked previously), nor an external drive, nor a Belkin USB hub (which had previously worked).
The Device Manager shows nothing wrong. It's as if the port is disabled. I used microsoft's instructions to edit the registry concerning "DisableOnSoftRemove", but that changed nothing. Any clues as to what might have changed here? Did an update mess things up? Don't see any other reports on this issue in the forums (vaguely similar, but not the same). USB port was working perfectly for two weeks, then "POOF", nothing.


New Member
tks leeshor, that reference helped. As I mentioned, I didn't think anything was wrong with the USB devices, or connectors. But following part of those "guidelines", I uninstalled the drivers, rebooted and let windows 8.1 reinstall the drivers. Funny enough, after that, then NONE of the USB ports were working, neither on the docking station nor the SP3 itself. After a few retries, I MANUALLY searched for USB drivers already existing on the machine, rather than letting it find new ones over the internet. This method, after 2 more reboots got everything working. I am wondering whether new drivers available via an update aren't working properly and I needed the previous versions? Anyway, its fixed and yr helpful post sent me down the correct path (eventually). Tks very much.


Well-Known Member
If it found drivers on y0ur Surface they were likely the newest drivers and the old one should have been overwritten. I have had similar issues with my Win7 desktop. I plug lots of different devices into my systems regularly and it gets confused now and then.

Marked as solved.