Desktop IE11 slow to open

Discussion in 'Microsoft Surface Pro 3' started by Telstar2112, Feb 14, 2015.

  1. Telstar2112

    Telstar2112 New Member

    Joined:
    Feb 14, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I have had my Surface Pro3 i7 for about 2 weeks. I use it almost exclusively in the desktop mode. When I click on the icon for internet explorer it takes between 22 and 60 seconds to open. I tried disabling any add ons or plug-ins and have set the bare blank Google page as my home page. Happens both at home and at work. Anyone have any idea what could be causing this?

    TIA,
    Telstar2112.
     
  2. theveterans

    theveterans Member

    Joined:
    Feb 7, 2015
    Messages:
    193
    Likes Received:
    15
    Trophy Points:
    18
    Mine opens instantly on my i5/256. You might need to reset IE and then disable addons one by one to see which addon is the culprit.
     
  3. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Go to Add/Remove Windows Features and remove IE and reboot and then re-add IE and see if it works better.
     
  4. r0b123

    r0b123 Active Member

    Joined:
    Jul 30, 2014
    Messages:
    217
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Issaquah, WA (USA)
    My Device:
    SPro3
    In addition to reinstalling IE, try setting your home page to blank. Does Chrome or FireFox start up slow if Google is set at your home page? Could point to a slow net connection? Also, make sure you don't have any viruses or spyware as something in the middle might be intercepting your data.
     

Share This Page

Search tags for this page

ie11 slow 2015

,

ie11 slow loading pages