What the HECK is inside this part of the SP3?!?!?

Discussion in 'Microsoft Surface Pro 3' started by spinedoc77, Oct 28, 2014.

  1. spinedoc77

    spinedoc77 New Member

    Joined:
    Jun 26, 2014
    Messages:
    8
    Likes Received:
    3
    Trophy Points:
    3
    OK this is the 3rd SP3 I've received that has this issue, it's utterly baffling to me. I keep swapping them out and keep getting this issue. I have this one square in the upper left corner that does not detect touch at all, but it does detect the pen. It's sporadic, I can reboot and it's gone, or let the sp3 go to sleep and sometimes it's gone, but it always eventually returns.

    This latest SP3 I got is only 2 days out of the box, I've probably only used it a total of 5 or 6 hours and it's already doing this. Having 3 of these fail like this you would think it's something that I am doing, but all my SP3 does is either sit on my nightstand next to my bed plugged in or it's in my laptop bag, that's it. It doesn't go near magnets, electricity, or anything weird I can think about.

    Anyhow here is a picture of the affected area. Does anyone know what is behind this area? Maybe it's hardware that is bad or something? I have to exchange this now for a 4th replacement, sigh.
     

    Attached Files:

  2. ctitanic

    ctitanic Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    2,194
    Likes Received:
    577
    Trophy Points:
    113
    Location:
    Hollywood, FL
    My Device:
    SPro3
    Try recalibrating the screen.

    Capture.JPG
     
  3. spinedoc77

    spinedoc77 New Member

    Joined:
    Jun 26, 2014
    Messages:
    8
    Likes Received:
    3
    Trophy Points:
    3
    Thanks. I've tried to recalibrate several times. Even during recalibration it won't detect my fingers in that spot.
     
  4. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,326
    Likes Received:
    1,279
    Trophy Points:
    113
    What's your purchase location? Sounds like a batch of bad screens and a particular location would likely have all the same batch... even sequential numbers within a batch. although it depends on where in the mfg process it went sideways. Then again it could be a side effect of alien technology... :)
     
  5. spinedoc77

    spinedoc77 New Member

    Joined:
    Jun 26, 2014
    Messages:
    8
    Likes Received:
    3
    Trophy Points:
    3
    1st purchase and first 2 replacements were in Paramus Nj, the latest replacement was in Wayne NJ. At this point my money is on alien technology lol.
     
  6. bluegrass

    bluegrass Well-Known Member

    Joined:
    Nov 11, 2013
    Messages:
    1,300
    Likes Received:
    193
    Trophy Points:
    63
    Location:
    St. Louis, Mo
    My Device:
    SPro3
    Have you tried using a different finger or asking someone else to test it?
     
  7. Kris

    Kris Active Member

    Joined:
    Aug 21, 2014
    Messages:
    644
    Likes Received:
    81
    Trophy Points:
    28
    My Device:
    SPro3
    I had the same issue with one of my 5 returned SP3s, Best Buy said they tested it and called me a liar. Past that no idea how to fix it. I tried screen calibration, reinstalled drivers even factory resets but the issue kept happening after using it for a little while. Only thing to do is return it and hope for better luck next time...
     
  8. mohcho

    mohcho Active Member

    Joined:
    Apr 24, 2014
    Messages:
    317
    Likes Received:
    51
    Trophy Points:
    28

Share This Page