What's new

8.1 and HD 4000 driver

Quicky

New Member
Has anybody managed to get any version of the HD 4000 driver working with the Intel Graphics Control Panel on the Windows 8.1 preview? If I install the latest version available at Intel's site, the control panel crashes when trying to open it. If I rollback/update to the stock 8.1 firmware version, the control panel opens but is "blank" (dropdowns and text fields empty). Unfortunately a couple of my games need the control panel to sort out the display scaling issue that shrinks some applications on high DPI displays.
 

pierre118

New Member
I had the same, i think there is no solution at this moment. Wait for new drivers or go back to Windows 8.0. I did the last, because under 8.0 the control panel works fine.

I hope new drivers will come soon.
 
OP
Q

Quicky

New Member
I hope so too. The Steam sale is an absolute tease when half the discounted titles don't display properly.
 

pierre118

New Member
It works fine on mine, but I'm not using the stock OS image.
You mean with 'It works fine on me' that you have installed Intel drivers on Windows 8.1 with the Intel HD Control Panel? And which not stock OS image you use?
Share what you have done to get it work, because 'It works on mine' doesn't give us so much information.
 

wardo5757

New Member
You mean with 'It works fine on me' that you have installed Intel drivers on Windows 8.1 with the Intel HD Control Panel? And which not stock OS image you use?
Share what you have done to get it work, because 'It works on mine' doesn't give us so much information.
Yes, I have the Intel control panel working just fine. What I did was:
Injected the stock drivers into the install.wim that was taken from a Windows8.1 image that I downloaded from Microsoft. Then put that on a USSB drive, wiped and installed that image on my SP. The SP runs SOOOOO much faster than before, something isn't right with the image that was placed in our recovery partitions. Here is a link to what got me going: Things That Might Interest Nerds | Surface Pro: Dump the Factory Image. It?s for the Best.
 

bangsters

Member
wardo, did you upgrade to 8.1 preview from your custom install of windows 8? how is it? does it have the tile row issue of 6 rows going back to 4 rows after waking up from sleep?
 

pierre118

New Member
Yes, I have the Intel control panel working just fine. What I did was:
Injected the stock drivers into the install.wim that was taken from a Windows8.1 image that I downloaded from Microsoft. Then put that on a USSB drive, wiped and installed that image on my SP. The SP runs SOOOOO much faster than before, something isn't right with the image that was placed in our recovery partitions. Here is a link to what got me going: Things That Might Interest Nerds | Surface Pro: Dump the Factory Image. It?s for the Best.
I know the method, I used it to install 8.0. I tried it with 8.1 too, injected the 9.18.10.3165 original Intel drivers into 'install.wim'. But after the installation I got the same error as before 'GfxUIEx has stopped working' when I open the Intel HD control panel. What do i do wrong? Which stock drivers(version, link maybe?) you inject?Can you give me a more detailled explanation how you did it?
 
Last edited:

wardo5757

New Member
wardo, did you upgrade to 8.1 preview from your custom install of windows 8? how is it? does it have the tile row issue of 6 rows going back to 4 rows after waking up from sleep?
No, I created a custom install of 8.1 and it's flawless. All of the connection and power management issues are gone for me.
Edit: I just read your thread about the display issue, I didn't understand you completely here, the issue IS there on mine also.
 
Last edited:

wardo5757

New Member
I know the method, I used it to install 8.0. I tried it with 8.1 too, injected the 9.18.10.3165 original Intel drivers into 'install.wim'. But after the installation I got the same error as before 'GfxUIEx has stopped working' when I open the Intel HD control panel. What do i do wrong? Which stock drivers(version, link maybe?) you inject?Can you give me a more detailled explanation how you did it?
I injected 9.18.10.3071 Intel driver also the 14.69.24026.106 Marvel driver,there was one more that's not stock but I can't recall it, the remaining drivers are all stock. If you want to, give me somewhere to upload the image and I will put it there.
 
Last edited:

pierre118

New Member
I injected 9.18.10.3071 Intel driver also the 14.69.24026.106 Marvel driver,there was one more that's not stock but I can't recall it, the remaining drivers are all stock. If you want to, give me somewhere to upload the image and I will put it there.
Thanks! Where did you download the 14.69.24026.106 Marvell drivers? I cannot find them
 
Search tags for this page

gfxuiex

gfxuiex has stopped working

gfxuiex stopped working
intel hd 4000 driver windows 8.1
intel hd 4000 windows 8.1
intel hd 4000 windows 8.1 driver
intel hd 4000 windows 8.1 drivers
intel hd graphics 4000 windows 8.1
intel hd graphics 4000 windows 8.1 driver
windows 8.1 intel hd 4000 driver

Members online

Top